Sketchup 2014 Windows 10 Issue


#1

OpenGL Error the application requested more memory than what is available. Funny… worked fine in Windows 7 only started getting the issue after upgrade to Windows 10; any suggestions? Is there a patch?
Nvidia Quadro FX 770m 512Mb
(DXDiag Says I got 2Gb going to the Card)
8Gb Ram (6Gb dedicated to System, 2Gb dedicated to GPU, according to DXDiag)
Win 10
Don’t know the Nvidia Driver Number, downloaded it this week so it should be current.
2.9Ghz Core 2 Duo Intel T9600


#2

SketchUp 2016 is the only version that is intended to be compatible with Win 10. That’s as close to a “patch” as you’re going to get.


#3

The Win 10 upgrade can play havoc with your graphics. I tried upgrading 3 times and never got things to work properly with an Nvidia card. Win 10 basically ignored it.
I’m back on win 7 with that machine and will stay that way. I have win 10 on another machine and that works, but it came with win 8 and the upgrade worked perfectly.


#4

Yet another thing to check, if your computer is a laptop (as the m in the Nvidia card type makes me suspect):
In the Nvidia control panel 3D application OpenGL settings, check that either the global setting or the Sketchup application setting points directly to your Nvidia card - the Automatic setting prefers the Intel video chip that is present on most Intel-based laptops. Intel chips do not support OpenGL well. My screenshot is from a Win7 desktop so yours might look different, and my desktop has no Intel chip.

Anssi


#5

The problem I found with my laptop (which has an NvidiaM) was that no matter how you changed those settings SU was still using the Intel card. If you clicked the detail button in Opengl it always showed Intel.
It seems to be an issue with the specific class of card and Win 10. And it affected all versions of SU I have on that computer.
The same cards and setting work perfectly with win7.


#6

I downloaded and installed 2016 and it is working; I know what you mean about upgrading it took me forever to get everything working right after upgrading. The only reason why I went back to Win10 (This is my second upgrade) is because I got a new Xbox One and I couldn’t get streaming to work in Win7. My Computer is a Laptop indeed and I checked my 3D settings but I only have the Nvidia Card to choose from, my CPU doesn’t have integrated graphics according to CPU Boss.
Anyway 2016 is working so I guess I just have to purchase a pro license.
Thanks
Tyler