Sketchup 2014: License key lost, serial number not displayed


I had to build up my system partition. Sketchup 2014 worked fine for some days but now it asks for the license number.

Of course my emails of the year 2014/2015 are deleted by now. I don’t have any physical note. What can I do? Sketchup 2014 doesn’t even show a serial number. The help link leads to a not existing page. Only the upgrade link still works.

Is there any other chance? 2014 still worked fine for me.

hello, you can log in onto the sketchup website with associated mail adress, and then access “my apps” at the top right corner. You should be able to see your active licences

Hi Paul,

thank you for that. But are you sure there would be entries out of the year 2014 or at least 2013? I don’t find any purchase – but I did purchase a PRO-Version.

In my backup files I found a file named “Lic125675.skp14lic”. I can read it, too. But I’m not sure if this is crypted text and which part may be the key or the serial no.

Any hint?


the serial number starts with PA, then 3 digits, then 8 and then three characters:

You can then use it here:

to obtain the authorisation code, provided you know the email address, too.

just a small rectification, it does not always start with PA… for example, my licences start with TA…

For SketchUp 2014?

oh ok, I did not realize first letters were refering to the version, my bad. Look for PA then :slight_smile:

Okay, thank you for your informations.

I found out the serial number (2014 on Mac) by opening the incense file. Indeed it starts with pa-… and it seems to work in the masks of the licence manager.

Trying all my e-mail adresses there is only one which work with that serial number. But the account information says that the licence ended (trial version). That would have been a long trial :wink: And I have an invoice dated on 28th September 2013.

To make it a bit more complicated: I mistakely purchased a Windows version and the support transferred the key number for Mac. Might that be a reason for the empty account?

Is the last letter a ‘W’ ? There used to be a separate version for Windows and Mac, but that changed after a certain date (not sure when)
Try replacing with ‘M’

The serial number ends on … alm. Is that what you mean?

Maybe you can get another result using ‘ALW’ in the license manager…

Ah, that was a good idea but it doesn’t work. I just tried that.

The article number in the receipt says “COSU2013NFW-SU-PC” so that I am totally worried. I worked with 2014 all the years (maybe after an upgrade) and I only have a license file in the application support folder named sketchup 2014.

Sorry for this chaotic case. It is so long ago …

I got the license manager to send your 2014 license to your info@ email address. Do you still have that email account?

In 2014, use the License section to add the license. It should work.

Good news, thank you. And yes, still the same mail account.

It works! Great Job. Thank you so much. I will immediately make a print of your email and keep it for the next 7 years :wink: