Sketchucation Extensions

Since Fredo6 just released updates for a bunch of his extensions as well as for LibFredo6 I thought I would post this.

If you have the Sketchucation Extension Store tool installed AND you’ve used it to install extensions from Sketchucation, one of the cool features is the notice that there are extensions to update and the ability to update them in one swell foop.

Here I’ve opened the Extension Store panel and I see there are 6 extensions that have newer releases than the ones I have installed.

Click on the red button with the bell and the number and you go to another page showing the extensions with available updates.

Click on Update All. If you get any prompts about installing extensions choose to update them.
Screenshot - 8_19_2020 , 5_18_23 PM

When you are finished there will be a message box showing the extensions that got updated.,
Screenshot - 8_19_2020 , 5_19_04 PM

And when you click on OK, you get a confirmation that all of the extensions are up to date.

Again, this is for extensions from Sketchucation that you’ve installed using the tool.

This also updates your “bundle”. My current bundle is Orbital-PC-20. If I were to install Sketchup on another machine I could install the Sketchucation Extension Store tool, click on the download button to the right of Orbital-PC-20 and automatically install my bundle of extensions from Sketchucation.

There are a number of other features in the tool but this is good enough for now.


This is extremely helpful considering my pending change.

I need to look into that Bundle thing more though.


1 Like

It really is a useful thing but the bundle is created by the tool and so you need to use it to install the extensions.

It also makers it easy to add those updates to the next version of Sketchup when the time comes.

Thank you

How do I access the Bundle, or is it just created automatically?


It is created automatically as you use the tool to download and install extensions from Sketchucation.

FWIW, when you install the bundle it will get the latest version of each extension even if you haven’t kept your extensions up to date. I have bundles going back to SketchUp 2014 that I could choose to install instead of the one that was created while using SU20202 and I could choose to install that 2014 bundle and still get the current versions of those extensions.

You can also duplicate a bundle and edit it to remove the extensions you don’t want to auto install.
I do this regularly as I often install extensions so I can explain to people how they work, then periodically I do my housekeeping and remove the ones I don’t use. This help keep start up times quicker as you aren’t waiting for endless unused extensions to load,… which leads naturally on to Sets, another useful option in the SketchUcation Tool.

By the way, before anyone asks why they created it when they could have used the Extension Warehouse? It predates the E Warehouse.


I’ve gotten used to using the Sketchucation plugin to update those plugins, and it works pretty well once you figure it out. I’m wondering about this extension: top_LibFred6? It this genuine? Did this get installed as part of the bundle?

The rest of the extensions look like this:

That top_LibFredo6 seems to come as part of the LibFredo6 installation. Nothing to worry about, though.

When I go looking for it, it’s not at the same directory level as all the other extensions, but inside a resource folder associated with LibFredo6 along with a gazillion other such files, so you wonder if it’s even supposed to appear in the Extension Manager window. Just strange.

It doesn’t seem like it should show since it’s in the folder. No idea why it does.

This is the native Extension Manager @RTCool is showing, which (last I knew) is not synchronized with the SketchUcation Tools.

The file is a “plain Jane” Ruby file that does not register an extension itself (which is why there are no extension properties when you expand the entry in the native EM.

@Fredo6 can tell you what it does … unless it does something secret …

The SketchUcation Tools calls this kind of file a “plugin” rather than an “extension”.

Both tools let the user switch off this kind of file.

Top_LibFredo6.rbe is indeed not an extension, but a plain ruby file, in the subfolder.

So I don’t understand why it appear in the list.

One possibility is that the process of loading extensions has some mystery. In my case, Top_LibFredo6 is ‘Sketchup.required’ before I declare and register the extension LibFredo6.

So it might be that any ruby file which is required explicitly outside an extension registration cycle is considered an extension. Precisely

  • The previous extension registers with its subfolder
  • then come LibFredo6
  • because Top_LibFredo6.rbe is not in the subfolder of the previous extension, and LibFredo6 is not yet registered as an extension, it is considered a standalone file, even if not in the Plugin Directory.

I’ll see what I can do to avoid this strange behavior.


It’s mildly annoying because every time I launch SU, it gets upset about this not being signed. Other extensions aren’t signed either, but it seems particularly bothered by this one. Am I the only one seeing this, or do others see the same behavior.

I have the loading permissions set so not alert me to unsigned extensions so it’s not a problem. I’m really not worried about the extensions I have installed because I trust the authors and where they come from.

I’ll fix it, don’t worry. A lot of this code is ancient and predates the extension management of Sketchup introduced since SU2016.


Same for me as for Dave. I don’t see the point in the annoying warning, so I set my extensions load policy to “Unrestricted”.

I do see stand alone files listed in the EM because I do a lot of testing and such so I drop files in the “Plugins” folder often. I eventually manually move them elsewhere and periodically I (manually) clean out the preferences json file of the load listings for old files.

The issue should be fixed with LibFredo6 v11.1a.

For those interested, this is due to a weird behavior of Sketchup, whereby a ruby file which contains the statement Sketchup.register_extension is considered as an extension, even if the statement is commented out and the code never executed.


Oh wow, that isn’t right!

Thanks for looking into this.

It is actually an extension registrar file. It is normal for them to be listed in the SketchUcation tools.
But I’ve only recently been seeing them in SketchUp’s native EM.

I would consider it a bug. Fredo has opened an issue for this.

Thanks Michael. I had the Extension Store tool but forgot how to use it. I am old so I forget often. It worked and everything got updated.