Sketch up slow, freezes and internal error prompts

Would love some input on my 3D model. It is so incredibly slow, zooming in and out almost crashes it completely. I have done all the things, turned profiles off, turned off shadows, purged, fixed problems. Now when I try to copy + paste it prompts me with an internal error- I hit fix problems- and it says problems can’t be fixed. I’ve closed + restarted. Not sure what else to do. Working on pro 2023. Anyone have any suggestions? Thanks so much. -emily

We can’t do much without the file.

here it is drop box sketch up file

Here are two things confusing me: I don’t know how or why the axis corner lines are everywhere. And when I copy and try to paste I get the prompt to fix errors which won’t fix.


I’m looking at your model. It behaves very poorly for me too. One thing I have found so far by looking at entity info is that the model contains an absurd number of Text entities (54440!). I strongly suspect they are causing your problems. I’m in the process of tracking down where they are coming from. Stay tuned…

Thanks so much- I was also confused by that. The items imported from warehouse are the tub and faucets.

The problem are the tiles, I deleted them all and it behaves well.
You have a lot of loose geometry and tagged lines, at this point it would be faster and easier to model everything again properly than trying to fix the model.

Thank you- would you mind explaining what tagged lines means?

If you go to the tags tray and hide some of them, some lines and faces disappear, only groups and components must be tagged. I´ll share the fixed model in a minute. meanwhile you could check the free courses to learn how to model properly.

I think the problem is that all those Texts contain only spaces, so they are effectively invisible! They are nested inside several Groups (alas, without named instances so they are hard to find). I’ll see if I can delete all of them. Again, stay tuned…

Yep. Got rid of all those Texts and now the model performs quite smoothly on my Mac. I suspect they came along with some evil object you imported from the 3DWarehouse. Here’s the cleaned model (I also purged and fixed bad tag usage).

Bath 3D.skp (4.3 MB)

1 Like

I re modeled a bit of the bath so you can see how you must group objects.
Bath 3D.skp (1.8 MB)

As @francisquitof also found, the offending objects were the tiles. There were 6 distinct tile Groups, each with about 2200 blank texts per copy! I got rid of the bad texts while leaving the geometry of the tiles in place.

That’s a setting in Model Info->Components. Uncheck “Show component axes”. Despite the name, it affects Groups as well as components.

@slbaumgartner Thank you so much- this has been incredibly helpful. One question: how did the text get there? I built those tiles from scratch- do you think it could be from a setting I have on?

Thank you so much- I really appreciate your help.

Usually that sort of thing happens when an automated object builder goes amok. If you made them yourself, I have no idea. It would be incredibly tedious to create that many by hand!

I’m totally amazed how much better this is. You made my week- thank you! I’ve had this issue on other models I’ve created, so now I know what to look for.

1 Like