Sketch up Make 2017 : Components disappearing

Hi all

I use Sketch up Make 2017 for my joinery projects and hide components when they get in the way. I press "reveal all " ( maybe something else in the original version, mine is french) when I’m done to see the result. But suddenly it’s like the “hide” as turned itself to “delete” as I can’t find anywhere the things I hid previously. Very annoying. I can’t see what I’m doing wrong.

Share the ,skp file so we can see exactly what you’ve got. Maybe you have deleted the components. On the English version, anyway, Erase and Hide are next to each other in the Context menu. Maybe you’ve hidden the geometry within the components? Can’t tell for sure what you’ve done but there’s surely something you’re missing. If they are components and you have deleted them you should be able to retrieve instances of them from the Components panel.

Thanks Dave,

I didn’t find them from the Components panel, but thanks for the tip. I use SU for some time now (although with difficulty) so I’m confident I wouldn’t delete a dozen of components by mistake. I thought that this would be some sort of bug common to this old version, but I couldn’t find anything in the previous topics. I think I’ll make copies of the skp files as a backup.

LIke Dave, I’ve never heard of that happening before. Can I assume that you know that Unhide All (or what ever is the French equivalent) only acts within the currrent edit context?

Share the .skp file like I requested so we can try to help you.

SketchUp 2017 hasn’t changed in years. It didn’t just spontaneously start deleting components on you.

Ok now I found my missing stuff by hitting “hiden geometry”.

So you hid the geometry within the components?

chambre parents ok.skp (2.3 MB)

Usually I just right click+hide. I have no idea what I’ve done :smiling_face_with_tear:

You did what I thought an hour ago.

So to unhide the geometry you have to open the objects for editing first.
hidden

By the way, you have a lot of exposed back faces (the blue ones). You should only have white front faces exposed. Right click on the blue faces and choose Reverse Faces.

1 Like

Yes, I know that, but pertinent question.

But from the results @DaveR shows (and I was seeing myself at the same time as he was posting), you evidently forgot :flushed:

For future reference, if you have questions about what’s happening you your model, just go ahead and share it along with your questions. You’ll save yourself and those who are trying to help you a lot of time.

Sorry to have made you loose your time. I had never done that before

1 Like

I forgot what? I don’t understand

If you actually remembered about how unhide only works within the open context, you would easily have fixed your original issue.

2 Likes

I often do something stupid when not fully concentrating and that’s when I select an object to briefly hide whilst modelling in place, I inadvertently hit the erase which is directly above hide when using the right-click context menu, rather than using the edit in the menu bar where hide and un-hide are together in their own section!

When I go to unhide and get nothing, I go to Outliner and look for the greyed-out item to see if that’s the issue. If not, I go through all the context levels to see if I can unhide it as that is often the issue especially on my laptop if I was zoomed in and did not notice I was working in-context when I hid/inadvertently erased the thing that was in the way.

If all else fails thank goodness SU has 100 undo options available, even if I have saved after inadvertently erasing something - provided I hadn’t closed the file! It means I will have to then re-model what I was working on but since hide should be used as a short-term workflow, advised by all the experts it doesn’t take too long to redo - I then ensure I actually hide the object in the way and bring it back immediately I finish doing what I had to whilst it was out of the way.

As the immortal Homer Simpson would say DOH!

1 Like