Single lines become double lines during scrolling


#1

I am running Lenovo Erazer X700, Windows 10, 64bit with dual AMD 8950 cards set to 1920x1080 (monitor max), 60hz. All of my drivers are up-to-date.
My problem is with single-pixel lines drawn either vertically, horizontally or diagonally. When I zoom in or out, the width of these lines change from single to double width and back to single as I continue to zoom. And this occurs randomly, e.g. the width of the lines do not remain the same when zooming to the same repeated level of magnification: One time they’re single, other times they’re double. This is really creating a problem for the projects I work on. Is it my computer, the video cards, or the monitor? I doubt it’s Sketchup.


#2

It sounds like a graphics card thing.

Did this just start recently?


#3

Yes, but may have been as long as 6 months ago because I haven’t used Sketchup in that time.


#4

It might be a driver issue. AMD cards are known to have issues with OpenGL. Maybe try rolling back to an earlier driver version.


#5

AMD has been doing an awful lot of driver updates in the past couple months. I’ll try rolling it back and hope it works. Thanks for the suggestion, DaveR.


#6

Good luck. If you find a driver that works, please post the version. It might help someone else.

Who knows? Maybe they’ll release a new one next week that will fix it. That would be my luck.


#7

DaveR, this is dreamer941950 on my neighbors computer.
I rolled back to the previous driver and my screen has gone black. Do you have any ideas on how I can fix it?


#8

Have you tried to reboot the computer?


#9

I did reboot, but nothing changed. However, I was still able to get a vid signal on my television and was able to reinstall the newer driver again. So all is back to normal, which unfortunately means so is the original graphics problem. But, thanks DaveR. At some point I will have to look into getting different video cards I guess.


#10

How far back did you go with the driver?


#11

Gary as a test install Make v2016 and see if the strange “double-lineness” happens. (Separate versions can be installed side-by-side on the same computer.)

Make 2016: http://help.sketchup.com/en/article/60107

SketchUp 2017 overhauled the graphics pipeline and is now using OpenGL 3. It also tries to compensate for 4K and 5K monitors by making lines thicker. (This was not yet implemented in SketchUp 2016.)

Sometimes, if you set Display Scaling (Control Panel > Display) it can confuse applications.
So the question is do you have Display Scaling set to 100% ?


#12

Dave R
I only went back to the 1st previous version, but because of the blank screen problem I do not wish to roll back any further. However, the double-line problem got resolved when I used Make 2016 instead of 17. Thanks for your help, Dave!


#13

Thank you for the suggestions. I did have my Display Scaling set to 125% and changed it to 100%, but that did not make any difference. I then tried the same file in Make 2016 and the problem went away! Thanks so much for telling me to try that. It has helped me tremendously. I do prefer Make 2017, but at least now I can construct my projects in it and save them as 2016 to do the final preparations.
Gary Nichols


#14

DanRathbun
Setting the scaling to 100% didn’t help, but switching to Make2016 did. Thanks for the suggestion!


#15

Understood on the driver issue. Since SU2016 didn’t give you the same issue, it’s pretty clear the problem is your graphics card drivers. If you haven’t uninstalled SU2017, keep it. And keep checking for driver updates. Maybe eventually you;ll get a driver that works.


#16

Yes, you can use them side-by-side. However the two installers set a different MSIE browser emulation for the webdialog frames used by extensions such as Extension Manager, 3D Warehouse, and Google Maps Geolocation. The 2017 installer ups the version so that the Google Maps will run without giving a warning.

So, … post 2016 install, it is best to do two things:

1) In SketchUp 2016 especially, but smart to do in both versions, update all the Trimble extensions that ship with SketchUp from the Extension Warehouse (especially Dynamic Components as it was updated to deal with bugs arising from old browser emulation settings.)

2) Re-run the 2017 installer and choose the “Repair” option (so the browser emulation for “sketchup.exe” is set to v11. (Your running the 2016 installer will have set it back to v9.)
This registry setting is global for all versions of “sketchup.exe” running on your computer, so it must be set correctly to work best with SketchUp’s web services.


#17

DanRathbun,
Thank you for that additional information. I’d also installed Sketchup 2015. I’ll follow your directions, applying them to all three versions. I appreciate your help. Gary