Horizontal Pixel Loss


#1

When I zoom in & out of an object, different horizontal single lines of pixels disappear and reappear depending on where I stop zooming. I don’t see this happen in other programs.
My monitor is set to 1920 x 1080 (that’s as high as it can go).
The graphics card is dual AMD 8950’s.
I’m running Sketchup 15.3.331 64-bit on Windows 8.1.
Is this a fault with Sketchup or my monitor?


#2

It could be a fault with your graphics driver. Graphics drivers that ship with computers can be pretty “bad” to say the least. There is nothing like updating the graphics driver.


#3

It is your graphics card and OpenGL driver trying to “best” antialias fine lines drawn by SketchUp. As Aerilius says, you can see if there is a newer driver and/or fiddle with the driver’s settings.


#4

In the graphics card control panel 3D settings, features like Antialiasing and Anisotopic Filtering should be set to “Application-defined” or equivalent.

Anssi


#5

I updated the driver as was suggested,fiddled with the settings, and made sure 3D settings were changed to Application-managed, but problem persists. I’m 64 and have limited knowledge with computers, so trying anything else I’ve read on the net just leaves me scratching my head. It’s very disappointing to have such a powerful computer but not know how to use it. Is there any chance the 1920 x 1080 is not a high enough resolution?
Anyway, thanks to everyone for the advice.


#6

Given you’ve accomplished all that; Start SketchUp and look to the top menus.
Click … Window (top menu) and in the list that appears, click… Preferences
The System Preferences dialog appears.

In the left pane of the System Preferences dialog, click on … OpenGL
The System Preferences-OpenGL panel appears.
As shown in this image, you’ll see various Capabilities settings from which you can choose.

What you want to accomplish here is to select a setting with a higher Anti-Alias factor.
My guess is what you’re likely to find is the current setting incorporates Anti-Alias 0x

Anti-Alias 0x is the lowest setting in terms of image quality.
Click on a setting with a higher Anti-Alias factor, say, 2x or 4x
Then, click OK to close Preferences.

Close SketchUp and then restart SketchUp for the new setting to take effect.
Let us know if that helps.


#7

Geo, thanks for the suggestion. I followed them to the letter, but it didn’t change anything. Some single lines of pixels still disappear or reappear depending on the zoom factor.
However, I’ve got to mention something unusual I noticed: The house model I’ve been having the most trouble with is The Wentworth Mount by author Garden Crescent. When I go to Sketchup 3D Warehouse and download it from there, the “Edge Style— Edges” is not optioned. But if I download that same model from inside Sketchup, it is! That’s kind of odd, isn’t it? Anyway, I found that if I turn Profiles on, then all of the single lines of pixels stay visible at any zoom level. However, some of those lines become blurred at certain zooms. I would be tempted to think it’s my video card, except I’ve got a good one: AMD Radeon 8950. PLUS, I tried the same test on another computer with a very good NVidia card and the same pixels would disappear on it, too! Perhaps you could check out the model I mentioned and see if it happens on your PC.
Thanks again for your help.


#8

This one?


The edge style in the model file itself has the view of edges is turned off.
Thus, when you double-click on the file to open it in SketchUp, edge rendering is off.

However, if you import the file into an active SketchUp model…
…it will be rendered in whatever edge, face and other style settings are active.


#9

Thanks for the explanation; I should have known the answer.
By the way: That particular model (Wentworth Mount) is the perfect example for displaying the pixel problem I’d mentioned earlier. If you turn Edges on and then note the lower-left section of the model you will see a single horizontal line of black pixels in the white trim that, on my computer, disappears and reappears as you zoom in or out. There are other lines in the model which also do that. This happens on two different PCs I have, so if it happens on yours then I’m not alone. I only point this problem out because it greatly interferes with what I’m trying to do in Sketchup. Please let me know if you experience the same thing.


#10

Hi @dreamer9450

The “pixel problems” you’re seeing are merely edges that have been hidden.
Look to the View menu…
•Turn on the view of Edges.
•Turn on the view of Hidden Geometry
• Set the Face style to Monochrome (notice many faces are reversed)

Then look to the Window menu…
• Open the Entity Info dialog.
Select the entity in question … Entity Info tells you what it is and provides editing options.
Tip: Best practice it to keep Entity Info open as you’re modeling.


It’s not clear what you’re trying to accomplish with this model.
If you intend to bring it into the context of a larger model it would be wise to clean it up first.
That may prove time consuming; given the entire “house” itself is a single mass of raw geometry within the context of a component wherein reversed faces, stray geometry and various improperly assigned layers abound.



#11

Geo, thank you so much!! You have saved me from aggravation and possibly spending unnecessary money. People on other web sites were telling me I needed a better graphics card or a much higher resolution monitor! It’s finally obvious to me now that Sketchup is a MUCH deeper (<–failed to think of a better descriptive word here) program than I’d ever realized. I would never have suspected Hidden Geometry to be the culprit, mostly because the “missing pixels” were visible some of the time. Anyway, your explanation takes care of the problem for me. And to let you know what I needed the model details in Sketchup for: I like to build card stock paper versions of the models I like, and so because I have to use a screen-capture program to transfer specifically-magnified views into an editor, I needed all the details to be visible for print. I thank you again for the tremendous help you’ve provided (there are too many aspects of Sketchup I’ll never understand). My interest in Sketchup & modeling has returned!


#12

Glad you got your problem solved!

There is a lesson here for other posters: until you provided the specific model that illustrated your issue, people could only give generic answers that missed the real crux.