Sign in Error intermittent users


We have recently encountered an issue where certain users can login to sketchup and some cant, there is no pattern, it is a mixture of staff and students. We have allowed all our Google API’s access to sketchup and it has not resolved it. The users have tried multiple browsers, cleared cache, allowed popups and still has not resolved.

When the users login to the app using the direct url ( SketchUp for Schools)they get stuck on this:

Once you close the above, they are then in a loop of the sign in error.

If you try and access the app through the Google app launcher, you get a sign in error.

I have discussed with Google and our setup is correct and no issues with the user account.

Can I please obtain some guidance on this?

For account issues I would suggest you contact SketchUp Service and open a support ticket.

Hello Dan,

I have done this previously and no reply or assistance.

Note your MS Edge screenshot notes [InPrivate] and perhaps that is some sort of default incogneto browser mode? May not work correctly with the google SSO? and maybe run ping or tracert to to make sure nothing blocks outbound from your school.

Thanks for your reply, I have tried chrome, firefox, and edge. all are experiencing the same issue. Regardless of incognito or not.

It is definitely not blocked as some users are able to access and some users are presented with this issue, its intermittent between staff and students.

Got it. You stated “intermittent between staff and students” do you think its related to group policy or some network level access by chance (maybe different student network topology)?

Can you check route between both working machine and not working machine? Post results but maybe block out any early hops?

Hey haste, its the same device and same network just different user id’s that are in different OU’s. So users in the staff OU and students OU are experiencing the same issue. Where as some staff/student users on the same device and network can access.

Got it. So I guess all I would suggest is, see if you can get access to the firewall and perhaps enable logging on the router and maybe limit by ip address so you can replicate the login and then see if the router is blocking the url? That can happen for all kinds of reasons on higher level switches. You might get some idea also by installing wireshark and filter by and that might be more available. If it is in both Organizational Units like you said, then it might be network related? Just throwing ideas at it.

Perhaps SketchUp for Schools is unsupported ?

For general readership …

This topic should be reassigned to the Technical Problems > SketchUp for Web subcategory.

Thanks @DanRathbun, I have re-assigned, hopefully Support can assist.

Further information, we have tried Limited & trusted options in API setting in our google admin console, this has no impact to this issue.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.