Shortcuts don't work as they did before 2023

I’m on a windows computer. When I enter my ALT + Y shortcut to create a section plane, and then I hit the arrow keys to lock a certain axis, it’s as if I clicked “File” at the top left. I know this is likely because I’m using the ALT key. Before Sketchup 2023 this was never an issue. Also sometimes when I click SHIFT + Z to zoom extents, it doesn’t work after using certain functions (I can’t remember which off the top of my head). I have to click spacebar or escape first. This was not an issue before, I could seamlessly go from shortcut to shortcut and work quickly. Now my workflow is interrupted.

Is anyone else experiencing what I’m experiencing here? Is there a way I can change it back?

Can these go back to the way they were before?


Does the file menu opens when you hit Alt+Y or when you hit an arrow? If it’s when you hit an arrow, is it with any arrow or an specific one?
Regarding the issue going from shortcut to shortcut, you said you must click the spacebar to use another shortcut, but the spacebar is already a shortcut so it’s strange that some shortcuts work and other ones don’t. I’ll try to replicate this but so far I haven’t had any of the issues you mention with sketchup on my windows pc or MacBook.

1 Like

2023 did introduce an issue where using Alt in a shortcut could leave the menu in a highlighted state. We did fix that a while ago, but the timing wasn’t quite right for getting the fix into the last update. It is fixed in the next update. I can’t tell you when that will be, but will come back as soon as I am able to.

For now, if you have done something that left the menu still highlighted, tapping Alt, or any tool change, will free it up.

@DaveR has used Alt in some of his shortcuts, and may have other suggestions on how to live with the problem for now.

I got around the problem by just tapping Alt again after using the shortcut.

It seems to be specifically the up arrow. And I’ve noticed the shortcut-to-shortcut issue also happening after I am changing views, so for example if I press Alt + 1, and then Shift + Z to view. So it’s probably the same issue that’s happening. I noticed when I hit Alt again, the issue goes away. Thanks for the workaround Dave and Colin, and thanks for fixing it Colin!

It wasn’t me personally, but I am glad it’s going to be fixed.

The arrow keys could have made things worse. Alt activated the menu, now you’re pressing an arrow to confirm that you want to navigate the menu you activated.

Bringing this back up because I’m having an issue with my Standard Views shortcuts. None of the shortcuts I have assigned with the Shift and arrows are working, and I’m confused about this “num” key assignment because it didn’t use to be there. For example, when I created my Top View shortcut, all I did when creating the shortcut was press my shift key plus my up arrow at the same time. I use Windows, and I’m running Sketchup version 23.1.340. Any reason why this “num” key is being automatically assigned? I did some checking, and I’ve noticed that when I disable my number lock, I can use the alternate keys of my number pad as the arrows, but it won’t allow me to use the arrow keys when my number lock is enabled… very weird.
Screenshot 2023-10-21 093346

Num is the numeric keypad. You could set short cuts for both when the number lock is on and off. Then either one could work, though people are reporting problems with using Shift and arrow keys.

Rollback to v.23.0.419 - the last build with proper shortcuts.