Shortcut to update Layout reference file

layout
mac
featurerequest

#1

There appears to be two ways you can update a reference file imported into Layout. One only works when you have clicked on a viewport and can then context-click and choose update. The other is by going through File>Document Setup.

You frequently want to lock the viewport to avoid moving it by mistake. Then system 1 doesn’t work without first unlocking the viewport.

I find I am often switching between SU and LO, making regular updates, so it would be helpful to have an icon or shortcut key. I have not found a way to do either. It would improve productivity for me a lot.


#2

And if viewports are grouped, you cannot use system 1 without ungrouping, making it even more tedious!


#3

There is another way. Go ahead and quit SketchUp. Then, in LO, right click on a viewport and use Open with SketchUp to open the file again. Now when you make and save changes to the SketchUp model, they will be automatically updated when you return to LO.


#4

I hadn’t thought to try that. It still means unlocking a viewport and having to remember to re-lock it after. I was rather hoping for something really quick you can do on the fly.

Separating LO from SU has many advantages but it also has some obvious disadvantages, this being one. Another is that you end up with two files where, in other CAD systems, you just have the one.


#5

You would only need to unlock the layer once and you can re-lock it immediately after. Not an onerous task.


#6

Depends how many layers on those pages got the lock.


#7

You only need to unlock one layer to be able to update the reference by context clicking on a viewport.


#8

Great tip. I found the save Sketchup file, then change to LO and File/Document Setup/References/select reference file/ Update/Close to be cumbersome and slow. Thanks for the better way.


#9

Agree


#10

second file can be a lifesaver backup sometimes


#11

This bugged me too, for awhile, until I realized I could add a button to the Standard Tool Bar, which on my screen contains New, Open, Save, and now… Document Setup. When my referenced SketchUp file is on the normally locked “Unique Elements” layer and won’t automatically update when I save the SU file, I just click on the new button and voila, the referenced file is shown in red. Click on that, then select Update, and tada, all fixed. Of course the only real hassle is that now when you go to that Elevations page with all the pretty pictures and such, it takes forever to regenerate…(more RAM, more RAM, more RAM … sigh).
Thom


#12

Thom- Where do I find this mystical “Document Setup” button? I do not see it on “Customize Toolbar”.
Thanks


#13

Did you ever wonder what that down-pointing arrow is for?
Screenshot - 10_5_2017 , 6_18_25 PM

And then Customize, select the toolbar button and drag it up to the toolbar.
Screenshot - 10_5_2017 , 6_19_07 PM


#14

@gary_brian
In LayOut, right click on the menu bar–or toolbar. These terms can be confusing. (On my screen, it’s on the top.)

A pop-up appears, with the names of the toolbars you have displayed, an option to Lock toolbars and an option to Customize. Click that last option.

A dialog pops up, and those same toolbars you have displayed show up. On my screen, I have “Main Toolbar” and “Standard”. The Standard toolbar is where I have the commands: New, Open, Save (as icons) and Document Setup… Perhaps there is an icon for it, but I don’t really care.

Highlight Standard in this list, select the Commands tab.

If the default Category highlighted in the left pane is “All Commands” that’s fine, or you can speed things up by selecting the “File” category. In the right pane, scroll around until you find “Document Setup…

Click on it, and DRAG it onto the Standard Toolbar until you see a thing that looks like a tall, skinny capital “I” (the kind with serifs). When you see that, and it’s in the place where you want the command displayed, release your mouse button and there it is.

You can add all kinds of useful (and useless or redundant or idiosyncratic) commands in this same way. You can even make new menus. You can do this until there isn’t any more screen real estate to draw on. Or you can get back to work and make documents. :smiley:

Good luck,
Thom

Edited to add: DaveR beat me to the punch, and with so much more elegance. It’s important to note, though, than when dragging a command onto the tool bar, that I-shaped thing MUST appear, or nothing will happen, other than frustration on your part. (And, perhaps Dave’s because he’ll have to explain the obvious all over again. Helps to be REALLY well experienced in the software, unlike myself.)


#15

HMMMM! Perhaps we of the Mac persuasion are less richly blessed than our PC friends? I am missing a dangly down arrow.


#16

Did you try the right click on a blank spot on your toolbar?


#17

On my MacI can customize my LO toolbar by right clicking or by clicking View/Customize toolbar, but adding the File commands as icons on the toolbar does not seem to be an option. I can add a keystroke shortcut to open the Document Setup window, which helps a bit.


#18

Yeah, there is no “add a button” option. Just locate the command you want, DRAG it onto the menu.


#19

As a fairly recent convert, I can attest that there are many differences in SU and LO between the PC version and the Mac version. This appears to be one… Any other Mac users / experts out there to chime in?


#20

@gary_brian Well Gary (or is it Brian?), I am a long time Mac/SU/LO user. I can find no equivalent to the downward pointing arrow in the icons available for the toolbar so I suspect you can only do this using drop down menus or shortcuts.

There certainly are differences between the PC and Mac versions of the software but they are not all in the PCs favour. This just happens to be one of the ones that is.