Shift key defaulting to zoom - I can't select multiple objects

I just downloaded the web version (paid). I’ve used Sketchup intermittently over the last 15 years, so I’m familiar with commands. When I attempt to select multiple objects by selecting one and hitting the Shift key I get a default to the zoom command and can’t select multiple objects. Anyone know if this is a problem with the web only version (I paid for it, not the free version) or a problem with my keyboard?

Is this in the web-based SketchUp Shop that you indicate in your profile? If so, what browser are you using?

I’m using Edge. I just purchased the version 30 minutes ago, so I’m guessing it’s 2020.

Sorry, Yes, it’s Shop.

So there have been some reported issues with Edge. Microsoft made changes to it that broke some things like keyboard shortcut handling. You could switch to Chrome. Also check to see if there’s a very recent update to Edge.

2 Likes

I’ll try both of these things, thanks.

Works great in Chrome, thank you DaveR!!

1 Like

Has this been resolved? Shift key doesn’t work in Safari on Mac but it does work in Chrome on the Mac. Any tips to resolve?

What Mac OS version are you using? Please complete your profile.

Mojave 10.14.6. Cant even enter in dimensions on anything

See https://help.sketchup.com/en/sketchup-web/getting-started-sketchup-web especially this:

A recommended web browser: SketchUp for Web depends on WebAssembly, a new technology that requires cutting-edge browser support. For the best experience, we recommend Chrome 59+ or Firefox 52+. Although SketchUp for Web will work in Safari and Edge, we cannot confidently recommend these browsers as of this writing.

Safari is an amazing browser, and as for case where Firefox or Chrome are leading edge, Safari’s Develop mean has an Experimental Features menu, when you can enable whichever ones of those you’re intrigued about, without having to use Firefox instead.

The problem with reading the keyboard incorrectly is unlikely to be a WebGL related issue, and is something the developers should be able to fix. When I can I try to pressure them into supporting the system’s native browser, feel free to help me do that.

Just tried it on Safari, same OS version as you, and it works for me. One thing I use to debug things like this is to put keyboard in the menu bar (System Preferences), then click on it and have it show Keyboard Viewer. You can see the keys are as expected. If that’s working, then it’s somewhere between your keyboard and Safari.

There are some Safari specific bugs, where the shift key is not handled well, if you are on a keyboard that requires shift in order to type numbers.