Error in Sketchup Free Update

Hi all

Just yesterday (22 April, or 23 April in my time) Sketchup Free was updated. Since this update, I’ve been having trouble with the keyboard shortcuts. Below is a screenshot of said update:

Because of this, the following happens:

  • My ctrl key does not work as it should. For some reason, it selects everything and sometimes faces on my models disappear randomly. I also can’t use the Ctrl+Z shortcut because of this, and I cannot soften the edges my models like I normally can.

  • My shift key also doesn’t work properly, which is my biggest concern. Every time I try to navigate my model by switching between the ‘orbit’ and ‘pan’ keys using the shift key, the shift key switches to the ‘zoom window’ function, which is very irritating.

The last dot point in the screenshot above is what leads me to believe this sudden problem originated from this recent update.

Can anyone shed some light on this so this can be fixed?

Thanks

Just checked in FF and don’t have those issues.

Hi @NSWR600Class,

What web browser are you using and what kind of keyboard layout do you use (QWERTY, or some other region specific keyboard?) We did make some changes, recently, so we’ll do our best to root out what’s going on for you.

Mark

Hi

I’m on a Windows 10 browser with a QUERTY keyboard. I don’t believe it is region-specific.

Thanks in advance.

Have you tried using the app with the Google Chrome or Microsoft Edge browser? We’ll still be looking closer at this issue, but in the short term, I would recommend Chrome. On Chrome, you can also choose to ‘Install Sketchup for Web’ to add a launching shortcut to SketchUp that runs in a dedicated window.

Continuing the discussion from Error in Sketchup Free Update:

I have the same problems with the shift key and control key. When I am in obit mode and use the shift key to pan it goes to zoom window mode. When I use the arrow keys to lock axes, the model disappears. When I use the control key in move mode, the rest of the model is selected. This just started happening a couple of days ago. In the past, this didn’t happen; the only problem was locking up and having to reload the model. I checked mouse for operation and it is good; I even tried another mouse. Something was broken at Trimble. I am using Edge. I am using the Shop Web version

EDGE BROWSER/WINDOWS 10
Trying to lock to an axis holding SHIFT with Line or Move tools, the tool changes to the Zoom Window tool.

Start Push/pull operation: input of first number is always 0 whatever number is entered, additional presses of number key will put digits into the measurements window but do not have any effect on the geometry when Enter is pressed. This is both with the numeric keypad and top row number keys.

Other problems noted by others above.

Are standard desktop shortcut keys for L=Line tool, A=Arc tool, Spacebar= Select tool etc supposed to work in Free too? (I don’t remember) If they are implemented, they are not working for me.

I fixed the problem by using Chrome. Don’t know why Edge stopped working, but by a different browser.

Hey @IanT; thanks for confirming those details. Did you try activating SketchUp for Web in Google Chrome or any other browser? (The web app does support most default shortcuts).

Hi Mark, I don’t usually use FREE. My curiosity were why a user in another thread couldn’t get the Push Pull tool to work correctly hence my tries in Edge browser. No, I didn’t try in Chrome as I’m quite happy with Edge and didn’t want to add another browser for the sake of it.

This is the Edge version that has the trouble:

EDGE ERROR

I did notice @Colin posted about an update to Edge, so I just investigated. Even though my Windows 10 is up to date not pending updates, there is what appears to be a major Edge update available. The update available also has a new logo. (see the old one I were using circled)

I installed the Edge update and this is the current version I am now running:

NEW EDGE

This new update feels like it loads FREE much quicker than before. The keyboard shortcuts all appear to be working correctly and numerical input appears back to normal. Seems ok to me.

I’m experiencing similar issues on Google Chrome. On latest update Version 81.0.4044.122 (Official Build) (64-bit).

If I refresh my browser, the hotkeys work as intended for a short while then eventually (but quickly) stop working properly again. Hand appears instead of orbit, can’t get the paint bucket to appear it always appears as the eye dropper (even when clicking on the paint bucket icon) on the menu… etc. etc.

That version was working for me, but while I was testing a new version arrived: 81.0.4044.129

It still works. With Edge, version 44 has keyboard problems, but this one works ok:

Version 84.0.498.0 (Official build) canary (64-bit)

I had the keyboard shortcut issue where none of the keys worked properly and typically just kept deleting the whole project. Really frustrating when you naturally revert to using the keyboard. I am super happy to find this thread because now that I had updated Edge, everything works properly. Took me forever to figure this out. Thanks guys!