Multi-Select Tool Not Working Layout

I have been using Sketchup and Layout for years; I’ve been using the 2016 version for the last 3 years. I am currently trying out the 2019 version to see if it’s worth it to have a subscription, however I cannot get the multi-select tool to work to save my life. I am running Mac OS (Sierra 10.12.6).

For example, to select multiple text boxes in Layout, when I hold shift and click the boxes, nothing happens. Once in a while 1 additional box will be select (out of several), but that’s it. Has anyone else had this problem? I do realize my operating system is older, however Mac isn’t making updates for my old and faithful anymore. Is it working trying it on my laptop (running Mac Mojave 10.14.5)? I was hoping to keep the trial to one computer for now but not having this function is annoying.


I haven’t seen any issues with adding to a selection while holding Shift in SU2019 on my Mac running on El Cap. Have you tried the other Shift key? It isn’t possible the things you are trying to select are on a locked layer or are below something else is it? Can you share a LayOut file that shows this problem?

Hi Steph,

We have identified a bug in LayOut when clicking on entities to add or remove from the selection, and we are working on a fix for that issue. In the mean time, multiple selection should work more reliably using window selection.

Hope that helps and sorry for the inconvenience,

Adam, that’s one I haven’t seen. Have I just been lucky?

If you are careful with your clicks then you won’t see the issue. You’ll see it when you move the mouse slightly during a click - this usually occurs when you’re in the process of selecting a lot of individual entities as you tend to keep the mouse in motion when clicking. It gets interpreted as the start of a very small window selection, but if you don’t cross the entities bounding box it won’t get added to your selection. This also will only happen if you’re doing a shift+click, ctrl+click, or ctrl+shift+click.


1 Like

So I should be sloppier with my selecting? :smiley:

I have tried the other shift key…doesn’t work.

It doesn’t matter how sloppy or careful the select selection is - it does not work.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.