LayOut 2018 - User Interface Differences


#1

Hi,

I have installed the new SketchUp 2018 Pro and have noticed some user interface differences in Layout. Please see below:

  1. When trying to select more than one object - it has become a bit more difficult and requires a couple of clicks on the object before selecting or sometimes it still doesn’t select more than one object at all.

  2. Dimensions - For some reason Layout will not let me pre-set the color of my dimensions so that it is done in a document once-off instead of trying to change individually at the end of a project.

  3. If I select more than one dimension with different entities and change the entities to all match it does not accept the changes unless i do them individually.

Is it possible to fix these issues or is there a setting for me to change on my side?
Thank you.


#2

I am having issues with item 1 as well. Shift clicking multiple objects is not working well at all. It just won’t select anything, Especially noticed when shift selecting grouped items.

I’m also not a fan of how selecting items works now in layout. I click an object to try to move it and 8/10 times all I do is move the pivot point. Very frustrating.


#3

Ditto. Multiple select is bad. I thought it was just my machine.


#4

The pivot point thing is extremely annoying particularly for text objects


#5

I have the same problem: Shift clicking multiple objects doesn’t work at all. To add to an existing selection I can only use Shift + Click and drag to make a selection box.


#6

Has anyone from the SketchUp Team acknowledged this? It’s really awkward to use Layout now.


SU & LO 2018 Issues
#7

Not that I know of. I’m new in the Sketchup Community though, and I don’t know how this normally works.


#8

I am also having the same problems with Shift + Click. Sometimes it would seem that you have to actually click slightly off the the object to get it to select. This is a very annoying bug that is killing my productivity.


#9

Hi all… I have been looking into this on the Mac and I have not been so far able to reproduce what is being described and appears to be consistent with 2017 behavior.

We have added the ability to select objects the same way you can in SketchUp, (adding the option key to add and shift+option to subtract) but have kept the Command + (select without moving) that works in conjunction with the above.

Does this occur more frequently with certain entity types? Text, SketchUp models, LayOut entities…?

I really want to get to the bottom of this.

Trent


#10

Hi Trent,

Thanks for working on this.

I didn’t know to use the option key or shift+option in Sketchup or Layout; I have always used the Shift key to either add or remove an object from a selection of multiple objects.
Anyway, I have now tried also using the option key instead of the Shift key in Layout but that does not work either. (it works in Sketchup)

As I mentioned before the only way I can add or remove to a group of object is using the Shift (or the Option) key and then ‘Click and drag’ to make a selection box. Just Shift and click on the object I want to select doesn’t work anymore.

The version of Layout I have is 18.0.16976
I’m using a Mac book pro with MacOS High Sierra ver 10.13.2

Thanks
Chiara


#11

Sorry Trent, I’ve just realized I didn’t answer your question:

it happens with all types off entities. I use mostly pictures, sketchUp models and labels.
And for me it nearly never works.


#12

Having the same issue with Shift + Click to select multiple entities on Layout 2018. Recently upgraded and never had any issues with previous versions. Doesn’t matter if one entity is already selected or not. Shapes, lines, text boxes, dimensions, and models.


#13

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.