Shadows not working on new laptop

SU version 2014.
Laptop is MSI GS65 Stealth
Graphics Card: NVIDIA GeForce GTX 1070 with Max-Q Design
OS: Win10 Pro 64-bit

In my GeForce Experience program they offered 2 drivers: one was “game ready” and one was a “NVIDIA Studio Driver 441.12” for ‘creative apps.’

I have tried both to no avail.

I have checked all my objects in scene to insure they are all set to both cast and receive shadows.
Have tried changing OpenGL settings but no luck.

Is your model created along negative blue, upside down?
What is the position of the sun, shining straight down?
Was / is your model geolocated, and if so, in a mismatching time zone according to the sun?

It would be best if you would share the model here, for others to check it out.

1 Like

test-scene-shadows.skp (1.7 MB)

Hold on i figured it out.
I hadn’t clicked a little button the Shadow settings window.

1 Like

Your uploaded image (OP) implied otherwise, although in text.

Second image: Use sun for shading clicked on, Shadows not turned on.