Shadow direction not correct and model too dark

Hi it appears I’m experiencing a few different types of issues with Shadows in Sketchup Pro 2023. I’m trialing this at the moment so may have set something incorrectly although I have tried starting new drawing new model from scratch and tested things do work as expected. Questions are why is the Sun rising and setting in the opposite direction? Any idea why the objects are dark when On faces = On? And why there are no shadows on the ground? Thanks.

Shadows on, On ground = On, On faces = Off, and in the morning
Here is how things look as a baseline. Note I have the True North pointing along the green axis as expected but the west side of the buildings are lighter in color, and there are no shadows on the ground, so appears to suggest the sun is rising from the West.

Note I’m only allowed to post one picture at a time so will try posting other views as replies.

Shadows on, On ground = On, On faces = On, and in the morning
Note everything is super dark once I have set On faces = On.

Shadows on, On ground = On, On faces = Off, and in the afternoon
Setting On faces = Off but adjusting the time to late afternoon shows result in the west side of the buildings getting darker.

If we rotate to look at the East side of the building it is brighter. So all in all it appears that the Sun is coming from East and setting on the West.

That doesn’t look like you are getting shadows

Can you post the file here?

@Elmtec-Adam thanks for replying. Here is the model file.
buildings.skp (10.5 MB)

I just opened your model and the time in all scenes is 5:17 PM @ UTC+8:00.

When I change the time zone to UTC-5:00 (EST in the U.S.) the shadows work normally.
Note that non-geolocated models may use a default of Colorado, U.S. which is UTC-7:00.

Also the model is not geolocated.

It may help if Use sun for shading is checked.

Basically the reason everything is dark is that SketchUp thinks that it is after sunset in the +8:00 time zone. I geolocated the model to Perth, Australia and sunset shows as about 5:16PM for 6/25/2023 (which is winter.)

Where are you located? Sunset will be later if the model is located in the northern hemisphere.

EDIT: I geolocated the model near where it once was:
40 N Lat, 105 E in Northern China and the shadows look okay.

  • So basically Geolocate the model
    File (menu) > Geo-locatation > Add …
1 Like

OMG you are right. I’m travelling around and happen to be in China atm. I guess the issue was the model info part has Colarado as default and then I happened to set to UTC+8. As soon as I updated to UTC-8, or update to a sensible Long / Lat and leave as UTC+8, it works. Thanks!

1 Like

I am in Boulder in Colorado, and although that’s the default, the model still misbehaved until I set the location to the default.

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.