Shadows not correct

Hi. Newbie to SketchUp so probably missing something simple!
I have oriented by drawing correctly. I have manually created a location - Dublin, Ireland - but when I display shadows, they are not correct. Sun is in the wrong position.
Is there another step I’m missing?

What do you mean it’s in the wrong position? Show us at least a screen shot of the model if not the SKP.

src="//discourse-cloud-file-uploads.s3.dualstack.us-west-2.amazonaws.com/sketchup/original/3X/1/d/1dfd32b09330f5aa52d82ccf2ad23dcbb91eec68.JPG" width=“644” height=“500”>

Hi. Hope this image works!

Try again…
.
.
.

It looks to me as if you’ve moved the axes. Try this: Move your model away from the origin so you have clear access to it. Right click on the origin and choose Reset. Then move and rotate the model as needed so north is aligned with the green axis. Do not rotate the axes.

By the way, the building on the right appears to be inside out. You should correct the face orientation so its white faces are out.

I assume the issue is that the shadows are cast along the negative red axis and you expect that direction to be west, not north? Here are two possible explanations:

One is that you have rotated the model axes. To check this hypothesis, right-click on one of the coordinate axes. If “reset” in the context menu is not grayed out, you have indeed changed the model axes. Clicking “reset” should then correct the problem.

Another possibility have made a mistake when setting the geo-location (you didn’t state the coordinates you used for Dublin or show the SU dialog to confirm them).

Don’t locate your model manually, import the location you are after through ScketchUp’s option “Add Location”. This will geo-locate your model, setting north correctly and adjusting to appropriate UPC+/-hours. All in one go.
If you don’t need the terrain, nor the screenshot, just unlock both groups and delete them.

P.s. sun’s north angle is 357.8 degrees (almost in green direction) for Dublin’s imported location. You wouldn’t get that right by just entering its coordinates.

1 Like

There are four parameters you must set to display shadows that accurately portray the real world.

Geographic Orientation — Relationship of True North to the model.
Geographic Location — Latitude and Longitude
Time — Year, Month, Day, Hour and Minute
UTC Offset — The difference between local time and the Coordinated Universal Time standard.

Check your model settings against what they should be in the real world.
Share the file if you have difficulty sorting things out.

3 Likes

Thanks for all help.
Resetting the axes, then rotating the model to the correct axis solved the problem.
Seems rotating the axes doesn’t work as suggested here:
http://help.sketchup.com/en/article/3000102#move-axes
That must be for something else!!
Thanks all!!

Rotating the axes and moving the origin do have some application but it does not change the north angle (there’s an extension available for that in the Extension Warehouse) and it doesn’t change where the ground plane is.

Solar North is well worth installing if you are trying to get accurate shadows.

1 Like