Setup Preferences on Mac

I just installed Sketchup Make on my Macbook air. I created a rectangle. I can manage the edges. BUT the push/Pull tool does not seem to work. Is there a setting that could be miss set?

try the ‘Rectangle Tool’ with ‘PushPull’ and compare it to your ‘Line Tool’ attempt…


Create the Line, Move the Line work, but push/pull does not.

I am sure there is some setting that I am aware of.


These may help…

The relationship between edges and faces

SketchUp won’t create a face where I want it to

In a word, no. So it sounds like there is a gap in your understanding of push/pull. Maybe Geo’s links helped?

Or perhaps @BruceVP there’s a gap in the closed loop of coplanar Edges necessary to create a Face.

SketchUp will create a Face provided the Edges that bound it meet the following conditions:
• The Edges form a closed loop.
• All the Edges are coplanar.
• No stray Edges, coplanar with the closed loop, project inside the loop.
• The Edges are not too short, say >.002 in length.

Thanks for your suggestions. Playing for a little while the push/pull tool worked so it is not a setting or preference. it is in the creation of the original rectangle .
So what did I do:
I created a rectangle . I clicked on the move tool and I was able to click on a line and change the size and shape of the rectangle. Then I clicked on the Push/Pull tool, clicked on the face of the rectangle and tried to drag the surface up. And nothing drags up with the tool icon.
Am I missing a step to define or make the rectangle into an item?


It sounds to me as if at some point you’re getting things off axis. How about this? Draw the rectangle and adjust the shape as you did before. Then try the Push/Pull tool. If it won’t work, save the SKP file and upload it here so we can figure out what you did.

I am curious about why you are resizing the rectangle after you’ve drawn it. Why not just draw it at the size you want it to be?

Sounds like when you used the move tool you managed to slightly twist the face.
Try drawing a rectangle and use push pull on it without otherwise modifying it

Snap Dave.

pre-snap box and dave

Thanks for taking your time to help.
None of it helped, BUT I shut down Sketchup, Rebooted, re-opened Sketchup,
Re-created my rectangle and this time, it magically worked just like it was advertised to.
I had done all this restarting before but it did not seem to help.

Now I can continue learning through the book.