Setting Dimensions of Imported Materials

How do you set the size of a custom image material imported into Sketchup Free? A month back or so, I swear I could import the material and apply it a square face that had the desired dimensions for the material. And then it would keep those dimensions when I applied the material to other faces.

But today, that doesn’t seem to be working. I import and apply it to the square face I created to size the material, but then when I apply the same material to another existing face, it’s not the right dimensions and way too big.

What am I doing wrong?

When I import images as materials in any version of SketchUp, I first draw a rectangle to match at least one of the dimensions of the material. Then I apply the image as a material clicking first at the lower left corner of the rectangle and then on the side at the known distance.

Edit: I went to make an example and I see that I am now getting the same result you indicate. Image applied to a nine inch wide rectangle. Then applied to the larger face behind but it is clearly too large.

Hmmmm… This is different. I wonder if @Mark might have any thoughts. Hopefully he’ll see this tomorrow.

If you are applying the material to a single face I believe you can right click on it and resize the texture with the pins. (I can’t remember for certain if that option is available in the free web version, though.

Hi Dave, thanks for replying. So I found out that I can Alt select (sample) the texture from my sizing face, and then apply it to another face and it does retain the desired texture dimensions. But I swear I was able to size the imported texture like you demonstrated a month ago and then apply that texture to other faces without having to sample to get the dimensions right. Did a recent update to the program cause a regression?

That’s my guess.

Applying the material to a group or component that is scaled could lead to this. Or then importing the image as an image and sampling it with the paint bucket tool (not sure if you can do that with the Web version) The material created in the latter version won’t show in the Materials browser.

In my example I imported the image as a material, not an image (I never do that anyway) and there was no grouped geometry involved. Both the rectangle on which I initially applied the material and the box were just loose geometry.

I can’t reproduce on chrome browser, mm template, but I do notice two materials added in the ‘In Model’ collection when importing an image as material .
Once placed on a Face, one is deleted.

This is on Chrome a few moments ago. Freshly opened session of Shop. 90mm long rectangles.

I wonder if it has anything to do with the size of the image in pixels.

Here are the steps to reproduce what I’m experiencing, and I am using Chrome. Using a newly created sketch …

  1. Create two 2’x2’ faces
  2. From menu, Insert → Choose local image → Click Material
  3. Click the lower-left corner of one of the squares and size the material image to fill the entire square
  4. Select the new material swatch now in the Materials panel
  5. Click in the second square and see that the image is not scaled the same as in the first square

My work around has been to sample the face of the first square and then paint into the second. But I’m pretty sure the material scaling established in step 3 above was used when just selecting the swatch from the Materials pane before.

Jep, there is a bug. Wonder if it’s related with the desktop version’s bug. @Katya

I don’t see this issue in SketchUp 2021. As always the size of the texture is determined by the size it is dragged out to. Here I’ve import the texture again on a 90mm wide rectangle and you can see it applies correctly to the second rectangle and the Materials panel shows the texture is 90mm wide.

Try importing as Image, create a component with that image and an extra edge.
Sample from the component and then apply to a face.
Watch the in Model collection.

Does it work the same if you import into an imperial unit model? In the metric one the material seems to get scaled by 254, so clearly related to metric/imperial conversion.

My first example was done using imperial units. The rectangle was drawn at 9 inches long and the box is 9 inches wide. I did in metric units only because Jack wrote, “I can’t reproduce on chrome browser, mm template.” Units don’t seem to matter here.

I believe it picks the pixel size multiplied by the unit setting.
Sampling picks the manually dragged size, choosing in the material inspector picks the multiplied.

When I make a 1 foot square using an imperial template, the material becomes 100 feet wide. An inch-wide was weird: 39’11" (?)

Hi @MikeWayzovski I’m asking about this internally and either myself or someone else will follow up. I’m taking a little time off so it might not be me, but I’ve called in for help. Sounds like Shop and Pro might be handling materials differently.

1 Like

Indeed! The web versions seem to be handling this differently than Pro. An image imported as a texture in Pro does exactly what I described in the instructions the OP was following. Here I’ve made a rectangle that is 9 in. long and applied the image to it as a texture. As you can see the dimensions show correctly in the Materials folder.

I believe this has worked correctly in the web version in the past but it currently does not.

Enjoy your time off.

Hi, this is Gopal from the SketchUp for Web team. Thanks for flagging this. This indeed is a bug in our code. We’ve filed a ticket to fix this. In the meantime, you can manually adjust the size of the material. Sorry for the inconvenience though. Appreciate you bringing this to our attention!


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.