Serious Bug in Sketchup 16 Preferences OpenGL Settings

I ran into this while setting up SU16.
Sometimes when you check “Use hardware acceleration” it displays the wrong options in the “capabilities list” and no hardware acceleration is used.
I checked SU 15: actually had the same bug but luckily I didn’t fall into the trap.
It may affect only some graphic cards. Nevertheless there is no way to tell how many existing SU users think they are running hardware acceleration but in fact are not.

I’m running on Window 7, 64 bit.
My Graphics card is a NVIDIA GeForce GT 520/PCIe/SSE2.
This is an excellent graphics card and runs perfectly with SU.
It supports 3 “capabilities” listed in the SU OpenGL settings dialog, and numbered as 16, 28, and 40. I use 40. They differ only in antialiasing. (I leave “max texture size” unchecked and “fast feedback” checked.)

If I uncheck hardware acceleration, the capabilities are numbered 101 and 102.
Check it again and the numbers are 16, 28 and 40. Fine.

BUT if I uncheck hardware acceleration AND CLOSE the System preferences window.
Open the window again. It shows 101 and 102. Now check “Use hardware acceleration”.
NOW IT only shows two different capabilities numbered 13 and 63! Click details to see that these options are NOT hardware accelerated (Microsoft NOT Nvidia)
So you think you have hardware acceleration but you don’t.
You have to do these steps:
• Uncheck hardware acceleration
• close the preferences window again
• open again
• check hardware acceleration
to get back to the correct list of 16, 28 and 40.

So every time you open and close the OpenGL setting window with the hardware acceleration turned OFF, it toggles to a different set of capabilities which purport to be accelerated.

Try it out on your configuration and see if you get similar results. So this may be a bug in the SU code that queries the card. Or it may be a problem with Windows or the card drivers that SU developers may not be able to fix for the affected cards.

In any case, I think all SU Windows users deserve a warning email to tell them to check their settings.

Barry Milliken

1 Like

I understand that when Hardware Acceleration is unchecked, anything else in the OpenGL dialog becomes meaningless. Also, no changes you make there are implemented until you have restarted SketchUp.


That’s true. But since the OpenGL dialog isn’t presenting you with correct choices when you do select hardware acceleration, it’s not possible to select them without figuring out and going through the process I described.

OGL capabilities of the graphics card driver are evaluated during SU launch, after enabling the option “Use Hardware Acceleration” (= OpenGL) a restart of SU is required to show the correct capabilties available. Also, these settings are typically not changed often, i.e. in fact many users did not even know their existence.

True but irrelevant to the problem.
Any user who wants to try no acceleration just to see what happens is trapped. He thinks he can easily revert to acceleration, and thinks he has, but he doesn’t realize that he has not.

1 Like

sure but nothing new, maybe a hint that a restart is required would be already sufficient.

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Just to add to this some info about Win10 and Graphic Cards.

I have found that certain Graphic cards fail with SU when you have upgraded to Windows 10.
For example,
In one of my setups, Win 7 with twin cards, Intel integrated 4000 and Nvidia GT630m everything works beautifully. I can set Nvidia to run SU, perfect lines, fast feedback, full textures…

Upgrade to Win10 and it goes to hell. You can tell it to use Nvidia as many times as you want but it will always use the Integrated Intel, which gives jagged lines, bad selection box artifacts and general poor performance.
I really wanted it to work with Win10 and have updated, upgraded, read everything, hacked registry etc etc etc for 2 weeks, but nothing will make that card work with SU on Win10.
Restored back to Win7 and everything works again. I have tried this twice, upgrading and reverting. I can only pin it down to a problem in Win10 and how it treats specific cards.

I know your system is Win7 so this isn’t quite relevant, but thought it was related enough to drop in here as the ‘bug’ you refer to may not be caused by SU itself but could in fact be a combination of OS, Graphic card and SU.

We’d also need a “Precision” (Low, Medium, High) drop down as well.

It is more complex than just picking a single attribute from a dropdown list.

All 4 attributes are interdependent. The Color Bit Depth mode* is the highest order choice, which determines available choices for precision, which determines available choices for Shadows (on/off) and anti-aliasing.

So you’ll see different choices depending upon if you choose a 24-bit color depth or a 32-bit color depth. When I switch hardware acceleration off (software acceleration) gives me only 2 choices of 24-bit color depth, both 0x AA, both with Shadows, one High and one Low precision.
With hardware acceleration on, I have 2 choices of 32-bit color depth, both 0x AA, one Medium precision with Shadows, and one Low precision without shadows.

This is why the choices are presented in a multi-column picklist.

(Be happy you have an Nvidia card and are not chained to embedded Intel graphics.)

* Sometimes you need to adjust the column widths to see the whole name of the attribute.

1 Like

Sort of related - I renamed my Sketchup.exe in the v15 folder last week to Sketchup2015.exe (to be able to choose it in the ‘open with…’ rightclick options in explorer). At that moment, openGl was giving trouble in V15 as well. The selection box window was ghosting just like on embedded cards, openGl settings were jumping around, even some Javascript functions didn’t work anymore. Renaming it back to Skecthup.exe fixed it all.
Conclusion: don’t rename the exe

Hi Denisroy, on win7x64 I don’t see that.Thanks for the offer but don;t bother to look. 99% of the time I open the files from within the program anyway.

1 Like

And as this whole thread’s point is, that making changes do not seem to actually change anything, something definitely needs fixing.

Right. There are keys in the registry named “sketchup.exe” such as MSIE browser version emulation. This emulation will not be set correctly when running any application with another name.
Also some of the “shell/open/command” paths will become invalid since the name of the target executable has been manually changed.

I have Win7x64 and the installers have added specific version “Open With…” commands to the SKPfile context menu since v2013, at least.

1 Like

We have suspected the performance drop in our Sketchup 2016 seats may be due to Sketchup 2016 not recognizing the OpenGL hardware. I have about 20 users between both of our offices that have complained about 2016 being much slower than 2015 using same hardware. (We have multiple operating systems and multiple different Nvidia based gpu’s, with some SP4’s) However, because we have a network subscription model, we cannot migrate back to 2015 to get the original faster performance. As possible workaround, are there specific settings in the Nvidia control panel we can set to manage settings? Would that help? I have gotten use to 2016 being so slower, but would love to see a fix if available.

Vincent: If you read my original post at top, you see the fix that worked for me.
But you may have a different problem.

Ok will do!

And pay good attention to what Anssi said: