Sending a floor plan to layout then it becomes heavily pixelated and unprintable

I have drawn a floor plan in Sketchup which I would like to send to layout and save as PDF so that I can print it out in A3. When I send the drawing to layout it displays as heavily pixelated and is therefore unprintable. I have no idea why and it’s driving me mad, please can someone help

When you first insert the SketchUp file into LayOut the viewport will be rendered as Raster. You can change it to Vector or Hybrid to get vector linework. If there are textures, Hybrid will also display them.

I expect you would get a lot out of the instructional materials on LayOut at learn.sketchup.com

Thank you DaveR you sound like a total expert and what you are saying makes perfect sense, my question would be how would I make this alteration?

I will definitely take a look at the instructional videos thank you for sharing but if you are able to instruct me as to how to alter the settings so that I can print my floor plan out I would really appreciate it. I need to print it out by tomorrow morning!

I was away from my computer. Select the viewport and look for the SketchUp Model panel in the tray on the right side of the LayOut screen. Find the Render drop-down list and choose the render type.

I find that setting Output resolution to High usually generates quite adequate printouts even when using Raster rendering. Screen resolution can be set to Low for speed. I use Vector only for exports to DWG.