Selective Error with 3D WebGL Viewer


#1

I’m getting a viewing error when I click on the 3D Web GL Viewer for select models. Instead of a pull/spin model, I get a black/blank screen:

What’s unusual about this error is that is only occurring for select models and not for all.

Models I’m having issues with are all part of the following collection:
https://3dwarehouse.sketchup.com/collection.html?id=uee26b67a-e105-4d58-a437-38621ab1b144

All of the other models that my company has developed have been fine (for reference https://3dwarehouse.sketchup.com/collection.html?id=u94dda16f-1cbd-4052-b8c1-038b699b484b). I was even able to utilize the 3D WebGL Viewer with a significantly larger/more complex model that utilized the “LSX Frameless Solar Modules - Clear” models as part of it (not yet available in our collections).

Attempted resolutions included:

  • Clearing the cache, reset of the computer, confirmed most updated video driver, and other general basic “check the computer first” tasks.
  • A new upload of the original model
  • Downloading one of the models and then a new upload
  • Downloading one of the models, saving with the latest version of Sketchup, and then a new upload

Computer Specs:

  • MacBook Pro, 2.4ghz duo core processor w/4GB RAM
  • OS: Yosemite 10.10.2
  • Graphics Card: NVIDIA GeForce 9400M 256MB
  • Browser: Chrome

I’ve been able to replicate this same issue on a couple other computers in my office, while others are not getting this issue at all.

Would love to get some feedback if anyone else is having this issue and if you’ve come up with any possible fixes.

Thanks!


#2

So far we have been unable to replicate. We are continuing to look into this issue! @Barry

Thanks,
AlexB


#3

The issue is only “Make this work on Chrome on specific Macs”? I’m very confused between this forum post, a phone call, and private message on this topic. Here’s what I know is true:

  1. It works on every Mac I can get my hands on, in Chrome or Safari.

  2. If WebGL is NOT enabled, we’d detect that, and you’d get our “swivel” view (little arrows)
    so that’s not the case.

  3. 10.10 (Yosemite) should have Apple’s most current video drivers, but who knows what Google does with Chrome in those instances. For example, Google disables WebGL in Chrome for the NVIDIA GeForce 7300 GT https://www.khronos.org/webgl/wiki/BlacklistsAndWhitelists

Does anyone else see this on Mac / Yosemite with Chrome?

-b


#4

Forgot to mention: the typical page people go to to confirm WebGL is working is

https://get.webgl.org/


#5

WebGL is working as other models do not have this error. In addition, I went to the link you gave me and I can see the spinning cube.

I’m getting the same error with other browsers (i.e. safari and firefox).

I asked one of my engineers with Sketchup Pro 2015 to create a completely new, from scratch, model of a LSX Laminate. I’m still getting the black screen.


#6

I would like to give you a few suggestions that I am not sure will work but may be worth a try?

  1. Add a location in your model, then export as a Google Earth KMZ file. Go to 3D Warehouse in a browser and upload that KMZ.
  2. I am sure you know that there is a 50MB limit, but let’s try reducing the model size. Could you make a copy of your model and reduce it? Perhaps there’s a portion of the model that can be deleted for the purposes of viewing on your mobile device?

Also, can you tell me if your model is a component or a group?

Thanks,
AlexB