Selecting with Move Tool Freezes SketchUp for 7 to 10 seconds

Hello,

SketchUp is freezing for about 6 to 10 seconds every time I select or de-select part of the model with the move tool.

The lag happens when the move tool is selected alone, even before anything is actually moved.

Once a part of the model is selected, and moved, repeated moves happen without freezing.

It is only selected/deselecting part of the model to move, that causes the freezing.

I noticed that CPU is running hot 60-90% during this selecting/unselecting.

The Model is not very complex and I was able to deal with even more complex models with 2018 version, without any issues.

I have disabled all extensions.

System:
MacBook Pro Retina 15-inch Mid 2014
MacOS Version 10.14.6
Memory 16GB 1600 MHz DDR3
Graphics NVIDEO GeForce GT 750M 2GB
Intel Iris Po 1536 MB

SketchUp Version: 19.3.252

I suspect this happened after upgrading from 2018. Unfortunately I cannot downgrade, since the license will not work with the older version and the models have been updated as well.

Please help as this is both extremely frustrating and has made SketchUp unusable.

Thanks,

Janaka

There are a number of longish topics on this subject. Search for ‘sketchup freezes on select’ or variants of that.

These threads are mostly if not exclusively about SU on Windows, but I see you are on a Mac.

What version of macOS? Your profile doesn’t say.

SU isn’t fully compatible yet (I think) with Catalina. If you are running that, see if you can revert to Mojave which definitely DOES work with SU 2019.3 which is what you say you have.

If that isn’t the issue, and you either can’t revert to Mojave, or you still can’t get it to work, it is possible to backsave your 2019 models to 2018 using either SU for Web, or the 3D Warehouse.

And you could talk to SU Customer service to have your 2019 licence revert to 2018.

Did you remove 2018 on the same machine?

Hi John,
Thank you for your response.
I currently have Mojave (version 10.14.6) and SU version 2019.3.

Thank you for your suggestion to contact customer support to revert to 2018. If I cannot figure out any other way to make 2019.3 work, then that is my only option, as currently SU 2019 is unusable, unfortunately.

Thanks

Hi Mike,
Yes, I installed 2019 and deleted 2018 from the same Mac Book Pro laptop.

FWIW you can have multiple versions on one machine, if you install 2018 back on the machine and enter the license info which belongs to that version (starting with ‘T’) , you could compare!

openGL:
turn your multi-sampling down to 0…

turn off ‘use fast feedback’ …

restart SU a couple of time…

then reset to whatever you use…

this reset my iMacs video card and improved navigation greatly…

also:

how big are your textures files…

file types also affect performance…

a random set I just tested…

 type      input size       SU 'sees'
in.jpg:    769.741 KB   >>   1.276 MB
in.bmp:    148.588 KB   >>  49.508 KB
in.png:    504.908 KB   >> 313.953 KB
in.png:     12.367 MB   >>   7.665 MB
in.png:     20.269 KB   >>  39.063 KB

although bmp looks good on small files, it is the worst if over 10 MB…

un-optimised jpg get bigger…

png is the best bet for ‘unoptimised’ input, but run it through ImageOptim.app to remove the cruft…

a properly optimised jpg can reduced by up to 13 times smaller than any of the others…

# future plugin plug...
myworld.jpg: 1.026 MB  >>  3.476 MB  >>  297.137 KB  as .jpg
myworld.jpg: 1.026 MB  >>  3.476 MB  >>    3.416 MB  as .png
myworld.jpg: 1.026 MB  >>  3.476 MB  >>    3.987 MB  as .tif
myworld.jpg: 1.026 MB  >>  3.476 MB  >>   10.428 MB  as .bmp
# the out is all SU loads after optimisation
# with NO visible quality loss and NO resizing ...

this is the output that SU will now use…

@jimhami42 posted the original [optimised?] here somewhere…


but, I haven’t finished my new optimiser extension yet…

john

This is off-topic, but a few days ago I revisited this to create a world animation without the Americas:

net-gifmaker%20(8)

What do you call that big ocean?

Could it be the “Gigantic Ocean” ? :wink:

2 Likes

Climate Change…

john

(sings) :musical_note:I’ve got this sinkin’ feeling. Whoa-Oh sinkin’ feeling …”

1 Like