Select Tool lag issue on Windows 10



the link in the top of this thread leads you to Intels site, I tried the one it linked to and also the older version. Both would not go with my system


I have no idea what to do now.


Try identifying your chipset and then looking for updated drivers.


now I tried it 3 times. I do need an update of the graphic card. But when I get to install it freezes and says “immediate reboot needed”. Tried rebooting and restarting the update, but same happened.


Thankyou, now I managed to update. However… it didnt fix the slow select tool. Any other suggestions?


tried the fix again and it worked. Thanks for helping out, sorry to bring up an old problem.


how did you do it? i don’t know how to use this link. I can’t copy or paste it.


How about this? Can you copy this and paste it your browser address bar?


Thank you all. I fixed the issue. I returned the computer and bought a different one that has the Nvidia card and it’s all good. I’m happier.
Thank you all for your help.


That’s the way to do it! :+1::+1:


just worked for me :+1:


so i guess i’m the only one who doesn’t know how to apply this fix? what i’ve got is a dropbox folder saved in my downloads, which is full of little files. if anyone can explain what i’m meant to do i’d be grateful. woodwork is my speciality computers come way down the line…


ok I’ve seen steves message from april and figured this one out! thanks


Oh my God, thank you, it helped me a lot.


Can you update the link?

Is not working for me, is redirecting me to a restricted contend in dropbox,



looks like it’s still active for me, please try this link:


I can’t download the fix from the link given above. Link seems to be has been turned off.

Can you share it again please?


Is the result of trying to access the file


Download: (1.2 KB) (283 Bytes)

Newly downloaded Sketchup 2018 - tools not responding
Sketchup 2018 running very slow on new PC
Probleme de ralenti sur sketchup

Sorry about that, here is the updated file: