Select tool icon doesn't change to indicate move or rotate functions

The select tool Layout stays an arrow and doesn’t change to a + when hovering over the move area on a dimension or to a triangle when trying to lengthen dimension legs or to indicator icon for rotation. Same for other entities like lines and shapes. It makes the process a complete guessing game.
I have of course rebooted my computer, then updated drivers on my computer and drivers for the Nvidia GeForce RTX 2060 (and set it to Studio Driver). I have also tried repairing the SketchUp download (as administrator) and even uninstalled reinstalled. I even made sure my drivers are updated on my mouse. I rebooted throughout my troubleshooting process.
Running this on Windows 10, 64 bit OS x64 processor.
Any ideas on a fix?

What element are you trying to resize?
Sometimes it gets tricky when the element is small and you need to zoom in.
Sometimes, the element is on a locked layer.
Sharing the document would provide more info.

any chance of some screenshots or an animated gif?

Interestingly, when I grab a GIF I continue to not see the curser change to the various icons, yet when I play back the GIF the icons all change correctly. So select tool is functioning correctly, but the graphics of the icon stay static.
FYI - I did a full recovery install of Windows 10 in case updates were the issue. Still not fixed - and now I get the pleasure of reinstalling all my apps.


Well, I think I have this solved - time will tell if the fix holds. I use a second monitor and had changed monitor settings multiple times during my troubleshooting, but never unplugged the monitor. Probably should have done that early on - cause once I was working solely on the laptop the issue was gone.
I plugged my second monitor back in and - voila! - all icons show up correctly when flying around an entity and select/rotate/pull all function perfectly.
Thanks MikeWayzovski and paul.mcalenan for throwing out some ideas to consider.