Sefaira Plugin, loading to blank "white box"

Hi there,

I’m having an issue launching the Sefaira Extension.
When launching I’m greeted by the “Loading Sefaira Plugin…” which quickly passes, this is followed by an empty “white box” as shown below.
The issue appears to be the same as Amy was having in this thread however, a solution was never posted. - How do I open Sefaira in SketchUp 2019?

In attempts to troubleshoot I’ve done the following:

  • Changed default browser to Safari -> Chrome and back again with restarts between
  • Installed the plugin on SketchUp 2019.3 & 2020.1 using both methods outlined below
  • Installed using both the .pkg installer file and through the extension manager with the .rbz file

Both downloads found here: https://support.sefaira.com/hc/en-us/articles/115001624152-Section-2-Accessing-Sefaira-and-Downloading-the-Plugins-

.zip file: http://plugin.sefaira.com/api/concept/s/plugin/download/sketchup/Sefaira_for_SketchUp.zip
.pkg file: https://s3.amazonaws.com/sefaira-installers/Sefaira_for_SketchUp.pkg

I’ve restarted and tried the above installations independently and together with no luck.

System details that may impact:
macOS Catalina 10.15.4
SketchUp Pro 2020 20.1.228
SketchUp Pro 2019 19.3.252
Session file: session.sefaira.zip (1.3 KB)

Thanks in advanced

  • Nathan

Hi @NathanL,

Can you give the directions here a go? I am hoping that that will resolve the issue for you.

Hi @niraj.poudel

Thanks for both the prompt reply and accurate instructions!

I’ve tried the given instructions on both SketchUp 2019.3 and 2020.1, while it gives something new it hasn’t resolved the problem, unfortunately.

Both give the same results, as shown by the screenshots below.

A couple of notes, the firebug console is giving me an error as you’ll see, unsure if this is related.

After I pass the expected Trimble login page I either get the same white box I had been getting or the page displaying “Sorry, we’re not sure what your final destination is.” If I select any of the options on the page I get redirected to the given webpage selected, obviously not where I want to be.

Thanks again for the help.

No problems here,
Screen Shot 2020-05-04 at 5.33.30 PM

Error, but when pasting the required line it continues

Greeted by a login page

There are two more login pages that continue as expected - didn’t include them as they have personal details.

Here I either get the show page or the plain white box,

@niraj.poudel

Just something I noticed while trying to self troubleshoot.

If I head to the https://sefaira.com/ page and login I get redirected to https://apps.sefaira.com/page/projects

The page is only ever a blank white page or I get a HTTP 500 error

  • Nathan

Having the exact same issue as OP with same OS. Still unresolved.
Not sure if this info is useful, but I had another poster suggest checking the ports and when I clicked the url maps.sefaira.com that ports need access to it runs an error message. Blank box sometimes shows 500 Internal Server Error message.

Hi @eperrygrove & @NathanL, thanks for sharing that information.

In the meantime could you please also visit apps.sefaira.com and try logging in there and let me know what comes of it (share the screenshot if you can)?

Second, before I escalate this issue can you both check to see if your firewall set up is in accordance to this doc?

Please let me know what comes of it.

Hi @eperrygrove & @NathanL, the issue that you guys were experiencing should be resolved now. Could you please give Sefaira another go and let us know what comes of it?

Hi @niraj.poudel,

As suggested it is now working.

For future users with this bug is there a solution to this or is it a backend issue?

Again, thanks for your help!
Nathan

Hi @NathanL thanks for confirming. In this instance this was a backend issue and therefore there was nothing that the user could have done to resolve it.

However there are instances where users get an empty window or cannot login. And this typically happens for a number of reasons related to their system settings (i.e., firewall settings, Internet explorer options etc). The solutions for those issues are housed in the “troubleshooting” section on our knowledgebase.

A google search should also lead one to those articles. Hope this helps.

Issue also is resolved my end. Thankyou for fixing so quickly! Appreciate the help :slight_smile:

1 Like

having same issue but on a windows 10 machine

Hi @leonard.sciarra, could you close SketchUp >> Open Internet Explorer on your machine >> verify that it is IE 11 or later >> Once confirmed, try clearing your history/cache/cookies etc from IE on your machine and checking to see if it solves the blank window issue for you?

Hi @niraj.poudel
I’m also having an issue trying to use the Sefaira plugin. I have been dealing with Sefaira support but so far with no success. I have tried opening the necessary ports and downloaded the sfs_conf.json file to the Sefaira temp folder, however I can’t get past the blank white screen. Can you please advise if this is also a back door issue?

SketchUp Pro 2020. Edison 20.1.228
MacOS Catalina version 10.15.4
Google Chrome version 81.0.4044.138 (official build) (64bit)

Regards
Kevin

Hi @KevK,

Thanks for following up here on the forum. I see that you are currently in conversation with my colleague @AlexG via Zendesk.

I’m afraid, both Alex and I are at an impasse here. We are currently trying to figure out why you are seeing an empty/blank screen for the console. I understand that users sometime see an empty plugin window but the console (after you copy the json file) showing up as empty leads me to believe that this has got something to do with your Safari set up (https://forums.macrumors.com/threads/safari-blank-page-bug.2204823/). Not sure if you have tried clearing history/cache/tmp files from Safari or reinstalling it yet?

Hi @niraj.poudel and @AlexG
Apologies I didn’t realise you were colleagues!
I use Google Chrome not Safari but I deleted the history from both and it now appears to be working :slight_smile:
I will test it out today and tomorrow and fingers crossed there are no more issues.
Thanks for both your help resolving this.
Regards
Kevin

HI Kevin,

No need to apologize at all. We have multiple avenues through which SketchUp Studio users can reach out with respect to Sefaira questions and it makes sense that you were in contact with @AlexG via Zendesk. Glad to hear that you got the plugin to show by deleting history from your browsers.