How do I open Sefaira in SketchUp 2019?

Just got SketchUp Studio 2019 (via the higher ed subscription through creation engine) and would really like to use Sefaira, but I don’t see any way to do it? Youtube features a plugin in SketchUp, but I can’t find it in the extension warehouse. How do I access it?

Hi @tysongersh, great to hear that you are looking to try out Sefaira. We have laid out a step by step process on getting folks up and running with Sefaira here -

The plugin can be downloaded here - which is the second section of the getting started page.

I hope this helps. Please feel free to continue any discussion here on the forum and we will make sure to help along the way.

1 Like
  1. These instructions should be available somewhere on the SketchUp Website, or at very least there should be a link to them on the SketchUp website.

  2. In your installation guide it says for SU 2019 you have to install the plugin manually, but the instructions to do so aren’t how you install plugins in SU…

Unless I’m mistaken, there’s no way to install a plugin in SU through the preferences window. This is what shows up when you click preferences in SketchUp:

Instead, you need to click on the Extension Manager, which is the ruby icon to the far right at the top of the tool bar

which opens up this window, where you need to click on install extension at the bottom of the window.

  1. Now that the extension is installed, how exactly do I open it? The instructions simply show it magically being open after you restart SketchUp, which is not the real world sequence of events…

You have to click on the extensions tab at the top of your screen 21%20AM

Did you guys not do a beta release or something to iron out all of these kinks in advance? SketchUp is supposed to be the common man’s modeling platform that equips layfolk with advanced modeling capabilities regardless of their technical proficiency or educational background. The ethos of the brand is centered around users being able to intuitively DIY through whatever it is that they are doing. This is made possible by the awesome design paired with the tremendous amount of online educational resources and highly engaged online community.

I know this was just released and to some extent tech is necessarily an iterative process, so this is to be expected. That said, if Sefaira is THE value of the purchasing SketchUp Studio, then this stuff really should have ironed out before it was consumer facing. For $900 this stuff should be spoon fed to purchasers. Maybe there are more differences between SketchUp Pro and SketchUp Studio that I’m not aware of, but if that is the case, then SketchUp needs to change their feature comparison chart because the ONLY noted difference between Pro and Studio is Sefaira.


HI @tysongersh. I completely agree with your assessment and the fact that we definitely need to do a better job of communicating the process better. To that end I have notified our knowledge team who develops content for on-boarding and they will be sure to create a workflow that helps new Sefaira users onboard and update/improve the knowledgebase article in question. I appreciate you taking the time to lay out the process here. Thank you.

1 Like


we have been trying to get Sefaira running on SU 2019 for use in our studies. For Windows systems it has been successful, using the somewhat clumsy work-around discussed in this thread. However there are students including myself running Mac OS, and many of the better computers at the school are also Macs, and the workaround does not appear to get Sefaira up and running properly for any of these machines.

It seems to be a Mac-specific issue - is there anyone running SU 2019 on a Mac who is succeeding in getting Sefaira installed and fully functioning? Or is there anyone more tech-savvy working on this issue already?!?

Superficially it works, ie, the RBZ file creates an Extensions tab with the ability to open up the Sefaira window. Also, the ability to tag modelled surfaces with Sefaira properties (wall, fixed glazing etc etc) becomes active. The persistent failure comes at the point of actually opening the Sefaira window, at which point there is a brief loading icon on the first attempt, followed by a permanently blank window. There is no invitation to log in, and no words, no buttons, no visualisations, no tabs - nothing at all!

As suggested by tysongersh in the post above, the only compelling reason to use the Pro version of SU 2019 (as opposed to other versions or other softwares,) is specifically to utilise the insights and functionalities of the Sefaira modelling plug-in. Personally, the price of the subscription, even at a student rate, is wasted money if Sefaira is no longer supported to work on my Mac OS.

Hi @rpitt,

Thanks for reaching out. For me to better assist I need to get a little more detail from you with respect to the operating system and the likes, so could you please send just a one sentence email to I will make sure to copy and paste your comments above to the ticket that gets created once you send that email in.

Sefaira should work equally well on a Mac and therefore it looks as though that this could be more of browser/network issue than the plugin itself. Either way, once you send in a “place holder” email to we can diagnose the issue there.

I had the white window symptom after I used the regular installer. The same installer worked in 2018. I later found the article that says to use the RBZ with 2019, and when I tried that, it worked right away. It continues to work correctly.

1 Like

It would sure be nice to just install it from Extension Warehouse from within SketchUp.

1 Like

Hi @niraj.poudel,

Thanks for your contributions to this thread - we do appreciate your attempts to help!

I am also having problems with the Sefaira plugin in SketchUp 2019 on Mac Mojave 10.14.4 (latest Mac OS version)

Plugin downloaded from your step by step guide here:

Installed Extension using the RBZ file in the Extension Manager but it shows as unsigned - please see screenshot in next post.

I get a white window of doom when I try to open the Sefaira Plugin from the Extensions toolbar…

Please can you suggest a solution? I have Safari but I don’t think the browser should be an issue as I am using the Mac desktop version of the software, rather than web browser version.

Many thanks!

Can you try to set Chrome to set to be the default browser?
That might trigger something.

  • close SketchUp
  • set Chrome to default browser

  • try again
1 Like


Thanks for your suggestion. As it happens, I was already using Chrome as the default. I tried closing SketchUp, changing to Safari, reopened SketchUp - same white window. Then tried going back to Chrome following the same process and still the same white window.

It is certainly a mysterious situation!

I will try later in Parallels but running two OS uses up resources so will probably slow down the system.
I can also try on a Windows PC but as @niraj.poudel mentioned this should all work on Mac…

Thanks again!

Hi @Amy, Thank you for reaching out. We will do our best to get this sorted out for you asap.

Could you please have a look here:

  • As it could be a network setup issue:

Sefaira Support

IT Setup for Sefaira

How Sefaira plugins work Sketchup Download the plugin here. The plugin is installed locally. The plugin calls domains such as Revit Download the plugin here. The pl…

  • having the session file would help:

If that is not the case then maybe you can share the Sefaira session file with,

since you are on a MacOS you will find the file at GO TO -> /tmp/Sefaira

Once you obtain the file please share it with so I can have our developers identify what might be going on in your system with respect to Sefaira.

Dear @niraj.poudel,

Thanks for your message. I have had a look at the network settings and cannot see how they would be implemented in my system.

However, I have installed SketchUp on the Parallels section of my Mac (Windows virtual machine) and I was able to get the Sefaira plugin to load even though it did not have a valid certificate and it appeared to be working (as far as a complete novice could tell).

Sefaira plugin still does not work on my Mac OS.

My Mac OS and Windows share the same network devices. Typically if I have a network problem it would be on the Windows side so I don’t think that the network settings/ports etc are causing the problem.

I will send send the session file to Sefaira, unless you have any other suggestions.

Thank you!

Hi @Amy,

Glad to hear that you at least have it working for you on your windows operating system. Yes please send us the session file because that is the file that our development team looks into to identify what might be going on.

We look forward to receiving the file and helping you access Sefaira on your Mac OS.

One thing that seems wrong in your setup, I think that SefairaStart is installed by the installer version, that doesn’t work with 2019. Only SefairaBootstrap is needed. You may be inheriting the problems that the installer version has. Try removing SefairaStart.

Th plugin did fail for me when I first installed it, using the installer version, but it continues to work with the RBZ installed version. I don’t have a SefairaStart listed.

1 Like

Thanks for the suggestion @colin

I went to try to remove SefairaStart but I cannot remove either of the Sefaira plugins - this is quite odd since I was able to remove the plugins previously (not that it helped).

@niraj.poudel The Sefaira plugins are both showing as “Unsigned” - is this normal?

Hi @Amy,

Yes the Sefaira plugin showing as “unsigned” is normal. Actually it shows up as unsigned for all users. We have received your session file that you sent to and I will have our development team reach out to you shortly. Thank you for your patience with this issue.

When trying to remove the extension, are you in Extension Manager, and have you clicked on the Manage tab? Can you send a screenshot of that screen?

1 Like

Yes, that’s where I was looking. The boxes to remove were greyed out.