Section Plane Issues: Cutting Not Filling

I am struggling with section plane. I am following along with the Commercial Interiors lessons on the SU website. I am trying to fill the top of my wall cut surface & I half of the plane is cutting not filling. I know it’s some issue with SU not recognizing that plane as a solid, but I cannot figure out how to fix this. Things I have tried:
1-copy the entire plane & paste in place
2-copy the entire plane, move up 1" pull down 1" to create 1" thick solid, then move the whole thing down 1" to the original height & delete all the extra cut lines I just created keeping a new top surface( this was painstaking & ultimately stupid as it did not work.

Any ideas? My file is too big to add here, but I have a few screen shots included.

Well this is my course so I hope that everything is working well for you…Did you model the walls yourself or is this the completed reference model provided with the Exercise Files?

See attached for what my version of the completed file looks like. I saw @DaveR commenting a min ago that it’s most likely that the wall group is missing a face or an edge.

Also note that I tend to place my section cuts outside of groups or components…not cutting into the raw geometry itself. Here is the cut and notice the wall group is preserved and the cut is outside.

Take a closer look at your walls and if everything looks good, feel free to upload here (or to cloud drive and share link) and I can take a closer look for you.

Another thought, and perhaps users that do Solid Modeling more than I can comment here…is to use the Extension Solid Inspector by ThomThom. In this case it’s telling me there are 5 ‘Surface Boarders’ that need to be corrected prior to the wall group becoming a true Solid. As you can see from my example above, the wall group didn’t need to be Solid in order for the section fill to show correctly…but it may be worth pointing out since it will help you identify potential issues to be aware of while modeling.

I have actually had a lot of trouble with this course:\ Yes I modeled everything myself by following along with the entire course. I am very familiar w/CAD, but have not used SU in over 10 years. I do not have a depth of knowledge in 3D modeling in general.
Yes, I am adding section cuts outside of the group. That second image was meant to show the style settings in case I am missing something there.
Yes & double checked all the walls & redrew some in places where my wall jogged or had a void where yours did not. I then tried to correct that top plane to be sure that had depth as mentioned in my OP. I am at a loss at this point.
I know what it is supposed to look like, but have been unable to get my file to cooperate. As I do not have a depth of knowledge at this point a very small mistake can be really detrimental as I cannot really trouble shoot with much benefit and/or a lot of time spent searching for a solution.
I saved it in 3D Warehouse as Section Fill Fail

Please share the link so I can take a closer look. Re: other troubles with the course, have you completed ALL of the SU Fundamentals Lessons? This course was listed at Intermediate level knowledge - meaning you need a good strong foundation to work from. Hope this helps and ping me anytime with questions - we’re all here to support your learning journey and help YOU overcome any hurdles that pop up.

Yes, I completed all the fundamentals courses and had no issues at all. I never needed to do any trouble shooting. The one good thing about running into issues is that I have had to learn more trouble shooting, which will be helpful in the long run. I am having trouble finding a link to share in 3D Warehouse, but it is there if you search the title: Section Fill Fail.

Found it…

I’m wondering if there is an issue with nested groups. Those walls are nested 5 levels deep in your model. Not saying that is modeling error, only that the section cut behavior may not cope with it correctly.

Edit: I downloaded to my Mac, and the model behaves the same as on the web version.

Absolutely. It’s a mess, despite my best fumbling efforts. I followed along as best I could, but didn’t know things were an issue until I was pretty far in. I opened the provided files & tried to match things by getting really OCD about tags & outliner. Somehow I have an insane amount of levels, groups/components. I don’t really know what happened, which is how I got myself into this mess. I have the desktop version. I am just trying to fix the issue now.

I found the problem.

There are two places where a face that would be sliced to create a section cut is from a different group than the adjacent faces that create the other sides of the section cut. The problem is masked because the cut edges created by the other group coincide with where there would have been edges if the face was present to be sliced.

To fix it:

  • move the section cut up out of the way (or delete it and re-create it later)
  • open the group for edit just above the ceiling group in the walls group
  • in the display panel, choose “Hide rest of model”.
  • orbit until you are viewing one of the locations in the attached animations, and add the missing edges to create faces in the group (I wiggle the cursor around an area where you can tell a face is missing before drawing the edge).
  • exit out of the group edit to the top level and either move the section plane back where it was or create a new one at that position if you deleted it earlier.

fix face 1

fix face 2

Edit: the attached animations also show various dangling edges that aren’t part of any solid object in this group, they really belong to other groups. You need to learn to use groups to contain complete conceptual objects, not just portions of them, and not to rely on objects from other groups to give the illusion that ones in the current group are complete.


-Okay I found the first issue, no problem. That has been adjusted. -The second issue is not yet fully addressed. I will keep playing around with it. Something is weird inside that void. I am clearly missing something, but that corner has been causing me concern since the beginning as it was supposed to be left open. It might be my book shelf also. I’ll get in there a little more.
-Yes, I know how groups & components are supposed to be happening, but sometimes I have inadvertently edited in the wrong group. I have made an effort to correct when I have noticed it, but sometimes if I am zoomed in really far I might think I am editing the correct entity when I am actually not. Small mistakes, which become larger mistakes as I move along.
Thank you for your thoughts on this!

1 Like