Section Plane Error

Hello SU world!
I have SU Pro 2019, and today I keep getting a remedial error that I can’t locate a solution for. I have several years of SU experience and have used the section plane tool many times, so this is quite strange. Today whenever I click the tool and try to place a location in the model it fails to initiate the section tool. After selecting the tool (using the drop down option or the button shortcut) the arrow stays as a white arrow and gives an error bell/notification when trying to place anywhere in the model. The arrow never changes to show the section face tool, and I am unable to select any other tool until I have escaped out of the process. Even the standard spacebar shortcut is unable to break out of the failed command.

I have a previous section plane in the model that works fine within the controls, I just can’t make a new one. Obviously I’ve tried closing this file and using different files only to experience the same failure. Any suggestions would be greatly appreciated.

Even though photos don’t really show the process (and in fact don’t show the cursor) here are a few for fun anyway…
Photo 1) placing the section plane unsuccessfully

Photo 2) showing a functional section plane while failing to place a new section

Yes, the section cut is turned off for clarity, showing a placement of the previous Section Plane.
image

Did you have another monitor attached? Sometimes, the window of the create Section Plane is of.

Yes, I operate using two monitors, but don’t appear to have any action on the second monitor.

So you can give the section plane a name?

Yes, the existing plane operates as should be, including the ability to copy and move. I just can’t make a new one from scratch.
image

I meant the Place section Plane:

And if you don’t get the Place Section Plane ‘Naming’ dialog you probably ticked the box to not show it again !
There is currently no built-in way to reset it…
BUT, there is a ‘hack’ involving editing a user’s file… see here…
Section names - Restoring the ability to name my own

1 Like

Nope, it locks up when I try a new Section. I made a copy of the original section cut and can rename that but the window for the option to “place section” is not available. I even tried a new model to see if it was a setting I switched off previously…

Just did the hack but that doesn’t effect the new placement of the plane??

Then try this: [Menu] Window->Preferences->Workspace-> Reset workspace.
Did you change the SHowSectionDialog? or was it set to true, allready?

Darn, tried the workspace reset option, but no go…
Trying Tig’s hack now…

The reset should work in the session, for the hack to work, you would need to restart SketchUp…

Copy that.
I did the window drop down hack first but that didn’t work even after restarting. After trying the coding fix
I couldn’t find a code line with the True/False option. 2019 didn’t show the same file name (I only had SketchUpCommonPreferences.dll)

image

My ‘hack’ was for PC, BUT the ’ SharedPreferences.json’ IS available on the MAC too.
It’s not a dll file.
Look in ~/Library/Application Support/Sketchup 2019/SketchUp
Where ~ is your home folder e.g. /Users/XXX

1 Like

Copy that. (btw I have a Dell7733)
I found the Shared Preferences file.
Unfortunately there is no code with the section tool dialog…

image

Check your version: Help->about
What version ?

Version 19.0.685 64- bit

If that option SharedPreferences.json is not set at all then by default it’s probably OK ??
Should be: “ShowSectionToolDlg”: true ,

Next idea…
I had assumed you might be a MAC user…
As a PC user you MUST install SketchUp in the proper way…
If there’s an issue the folders/files used by SketchUp can have read/write problems…

Here’s a fix…
If you haven’t done it properly, or perhaps you are just not sure, close SketchUp.
While logged in as your normal Windows user-account, find the SketchUp v2019 installer exe file - it’s probably in your Downloads folder ?
Select its icon > right-click > context-menu > “Run as administrator”
When prompted choose “Repair”
When it completes, try starting SketchUp and see if anything improves…

Installing any complex app in any other way can lead to all kinds of weird and unexpected issues - often revolving around file permissions…
So NEVER double-click an installer exe file to ‘Run’ it, it’s not the same thing…

1 Like

There is a maintenance release, download the new version and install the way @TIG explained.

Download here:
https://www.sketchup.com/download/all