Scenes all revert to the same in layout using matchphoto

Hi, Thanks for helping. I’m running Windows 10, Sketchup Pro 2018. I have loaded a photo (of a clients house) using match photo, I have four different window styles that I want to show this client - for/on the same window.

First I tried to do this with scenes. I now understand that I cannot change the geometry in a scene.

I read an old post that said to use layers. so…
I put the different windows on separate layers.
I tried exporting them individually to one Layout file. Nope.
I created scenes with each layer visible.
That doesn’t work either.

When I export to layout or insert into layout, the only scene that appears on all sheets is the most recent save.
I’ve tried not updating the references. That doesn’t work.
I’ve updated the scenes checking the Visible Layer box. Don’t know what that’s suppose to do but it doesnt’ do this.

I tried to make a copy of the matched photo so I could just put three of them on one page and use scenes from there – but I could not figure out how to copy the photo. Uploading another matched photo simply replaces the one on the page. Edit cut/paste doesn’t work.

And so, my questions:
Is there a way to export several different versions of a matched photo into one layout file?
Is there a way to make multiple copies of a matched photo on one page so I can use scenes?
and/or is there a completely different way of doing this that I’m just not getting?

Thanks so much.

You should be able to do this with just one “MatchPhoto” and multiple scenes.

Each updated scene in SketchUp saves a set of options (layers being one of them). And each scene may have a different set of these options saved.

So you can set up and save/update different scenes with different visible layers included in each scene. Meaning that each scene would show a different door/window version with that same “MachPhoto”.

Then in Layout you can show all these different scenes with different door/window versions.

Thank you G.H.Hubers. I have tried what you suggest multiple times, I’m checking the “visible layers” box when I update a scene, even saving every time, it does not work.
In the tray, I have layers just above scenes, when I click on the scenes, nothing changes in the layers even though I’ve saved them repeatedly. When I check or uncheck layers, it does what I would expect.

I just went back to try this again and this time, after creating and updating 3 scenes, when I click on the tabs for each scene, as I click, it just collects all three of the windows one on top of each other.

Do I “add scene with matched photo” ?? Is that the trick? every scene is a new matched photo???

Nope. That doesn’t work either.
I ran the sketchup checkup program - turns out I have to force SU to use my nvidia graphics card. Doh. I haven’t sorted that out - but I imagine this is the issue. I’ll keep you posted.

You can upload an example file with your scenes…

Getting your Nvidia graphics set to be used by SketchUp is a good idea but it’s not the cause of your problem with Match Photo.

It sounds like you were on the right track but I think you missed a step.

Here I’ve got three scenes, each with a different window. Before creating the scene for Window 1, I ticked the Visible Layers box in the Scenes panel.

After creating that scene, the tick box will remain ticked for subsequent scenes unless you click back on the Match Photo scene. I created the additional scenes for the other window options.

Save the model with Window 1 scene active. Then Send to LayOut. The first viewport shows Window 1. Copy the viewport within the LO doc and in the SketchUp Model panel, change the scene for each of the viewports.

FWIW, there’s only one Match Photo import and in this case I didn’t model the house, only the windows.

1 Like

(Dave beat me to it, more experienced!)
I had just figured out that whether creating a new scene from ‘MatchPhoto’ by using ‘Add…’ or by importing another (or the same) photo as ‘MatchPhoto’, thereby creating an extra scene, either way you get scenes that can have their own different set of layers saved/updated with them.
All these scenes could be used in LauOut and thus have different door/window versions displayed by different layers being visible. It’s all about including updated layersets in SketchUp and about having the SketchUp pages up to date in Layout.
I just did the same thing as Dave but with my own photo’s and window in SketchUp+Layout.

Thanks so much, You were correct about the graphics card - though I’m thrilled to have that working.

I’m wrapping my mind around the copy in LO part of this.

I have had the visible layers box checked - have been playing with unchecking and then checking again. Has worked once. Then not again. So I know I’m missing a step…

will re-read what you’ve sent.

Thank you so much!!

Edit: One thing I’ve noticed, when I select a different layer (in the tray) it keeps the last visible layer checked. Is this normal? Am I missing something in layers?

Thank you!

Scenes with visible layers is working. I clicked the visible layers on and off in the tray (also buried some garlic in the yard) and that seemed to make this work. Now, I have one of these successfully exported to Layout…and I’m back studying what’s next.

Edit: Problem solved. Thank you everyone!!

1 Like

You need to have at least one, visible active layer in LayOut, otherwise you can not create anything new.