Scene saving problem in sketchup 2021

When I save scenes, I always use “zoom extents” to make sure that scenes will align in Layout.

How I do it:

for example you have two objects, A and B.
Delete B, use “zoom extents”, save as scene 1.
press “ctrl+z” to recover B,
delete A, use “zoom extents”, save as scene 2.
press “ctrl+z” to recover A.
Save the file.

This is an easy way to make sure your scenes will perfectly align in Layout. It worked in any previous sketchup versions.
But not in 2021, when you try to save after you created the scenes, you will find this model is “beyond repair” or “unable to save your model.” or Sketchup collapses immediately.

Does this happen to anyone else?

I will try those steps.

@Adam @trent does this sound familiar?

Could you update your profile, if you are now on SketchUp 2021? If you still have 2018 installed, I take it that those exact steps don’t show the problem?

hi, thanks for the reply.
I never had this problem with any other sketchup version, not once in my memory, this issue is very new to me. Will it be there are too many plugins?

I doubt that plugins could cause this.

Do you have the same issue with your sketchup by those steps?

It’s almost 11pm, I didn’t try yet! I’m hoping that Adam and Trent will know of an existing issue. But I will test as well.

I haven’t seen this behavior you report but that’s a weird way of creating the scenes. Why not just right click on A and choose Zoom Selection, create the scene, right click on B, Zoom Selection, create the second scene? Fewer steps that way and you’re less likely to lose anything. A keyboard shortcut for Zoom Selection makes it even easier.

Hi all, no, this does not sound familiar to me. Sounds like it could be an undo issue with SketchUp but
going through the steps you have described I am not running into the problem with 2021.

Does this occur with just any geometry?

Trent

thanks for the reply. no particular geometry or object. it happens to me with two simple squares or any object. However DaveR has provided me another way to do it. It works even better, so at least for me it’s no longer a headache.

1 Like

FWIW, you could do this from Outliner if you want and you might consider using tags instead of Hide.

It’s an unusual behavior you report, though. I wonder if there are other situations where the same thing happens or if it might just be the phase of the moon or how you were holding your tongue.

Thank you very much for the thought.

zoom selection does not have a toolbar icon, I never really noticed this function, and as long as my way of creating scenes works I don’t really have an intention to improve it do I?

zoom selection is a much better way to do it, thank you again.

1 Like

No. It’s a context menu item because it depends on what you have selected.

Well, maybe if there’s a faster or easier or safer way of doing it, you do have some reason to improve your workflow.

You’re welcome.

By the way, if you want to create a keyboard shortcut for Zoom Selection, select and object in your model space and then open Preferences>Shortcuts and set it.

Yeah, there is always so much to improve.

Thanks again, I was trying to find its shortcut but there was none.
Didnt think of it that you have to select something before you go to the preferences.

That’s the way for any context menu items. It’s not the most intuitive but there you are.

one more question maybe you know how to set a shortcut key for “sample paint” under “materials”?

No need to set it. It’s already done for you. Get the Paint Bucket tool (B) and hold Alt to sample.

that is just great, after all these years, thank you so much, it really helps. Cant really figure it out until some one tells me

Watch the lower left part of the bar below the model space to see what modifier keys do what for different tools.

Screenshot - 3_11_2021 , 9_50_34 AM

haha, yeah, there it is. Should have paid more attention to bottom left corner instructions, it is useful. Thanks, you are so kind.

1 Like

thanks for your answers today.
I want to share with you these colours, hopefully they can be useful to you too.
I recorded them myself from the book, all in .skm ready for use.

Onedrive:
https://1drv.ms/u/s!Aj-hJGIQgp_rozofFCZtnprOTnbI?e=bFBNAU

And here is the story behind it, comes with subtitles.

1 Like