Scene dialog/ fix Hidden Geometry to SAVE display of Hidden Groups/Entities


#1

According to SketchUP User’s Guide (2006), the Properties to save/Hidden Geometry checkbox ON in the Scene dialog box is supposed to “Display HIDDEN GEOMETRY or ENTITIES that have been hidden using the Hide menu item or context command…”

Unless I’m missing something….this feature is broke !!

Simple experiment:

First:
Create a CYLINDER AND BOX group.
Within this group create two sub-groups named BOX and CYLINDER.

In the Scenes dialog box turn ON all Properties to save and save the scene as CYLINDER AND BOX.

Next:

Enter the CYLINDER AND BOX group again. This time Hide the CYLINDER group with either the Hide menu or Hide context command.

Uncheck Hidden Geometry in the Scene dialog box

(NOTE: this should disable the display of the “hidden geometry or entities as stated in the SketchUP User’s Guide”).

Keep all the other Properties to save checked ON.

Save the scene as BOX-CYLINDER HIDDEN.

Lastly:

Switch SketchUP’s display between the CYLINDER AND BOX scene and BOX-CYLINDER HIDDEN scene. The hidden state of the groups does not change.

Hidden Geometry toggle in the Scenes dialog box does NOT HOLD the Hide Settings.

This should be corrected.
The Properties to save should SAVE THE HIDE SETTINGS if unchecked.

Parting Comment:

Actually, the whole Hidden Geometry setting is counter-intuitive.

Hidden Geometry works differently from all the other Properties to save … All the other properties SAVE the values of SketchUP’s current display settings. The Hidden Geometry (besides not saving the property with the scene) attempts to display what is NOT currently in SketchUP’s display … in other words, it displays what SketchUP is Hiding in the display rather than keeping the Hidden geometry or entities Hidden.

Since Hidden Properties doesn’t work anyway, perhaps Trimble would consider making this property “intuitive” and SAVE THE HIDDEN STATE. not displaying the Hidden state of geometry and entities in Scenes.


Show Hide Geometry in Scenes for Animation
#2

pnpwalter,

For the topic of the scene properties options, it sounds like the old users guide probably could have been worded better.

Here is what is now in the users help center …
“The Properties to Save options are used to control the different properties that can be stored with each scene.” … “Hidden Geometry: Use the Hidden Geometry checkbox to store the hidden geometry visibility with the scene.”

In other words, the menu of options does not set the properties. If checked, it saves the property settings in the model for that specific scene.

In your example …
Since the “hidden geometry” property was not saved with the 'hidden" scene, when you switch to that scene, sketchup does not look to apply the Hidden property chracteristic to the geometry.

I hope this makes sense.

Cheers
CD


#3

Hi Chris,
That makes sense. My mistake.

It would make more sense if the property was named “Unhide Geometry” rather than Hidden Geometry.

If you check Hidden Geometry ON you always see the geometry that was hidden with the Hide command.

I’d like to see a command that saves the Hidden geometry as Hidden and as shown in the model after using the Hide command. Don’t know what that would be named.


#4

Not exactly. If you have the Hidden Geometry setting unchecked for a Scene, it means hidden and visible entities will remain unchanged when switching to the Scene from another. It means the Scene does not update what is hidden and visible when the Scene is selected. It means hidden entities remain hidden and visible entities remain visible.

All of the Scene options are consistent and logical. If an option is checked, the Scene uses the settings to update the view. If an option is not checked, the Scene does not use the settings to update the view.


#5

Hi Chris and Jim,
I still see a problem. I’ve conducted another very simple experiment. This experiment represents what is commonly done in architecture. An architect may create floor plans with and without furniture or with and without electrical layouts.

Checking the “Hidden Geometry” ON or OFF DOESN’T SAVE a property of the current
model view.
Experiment:

Step 1

  1. Create entities and make three groups: WALL, WINDOW, and FURNITURE.
  2. Check ON all the “Properties to save;” in the Scenes Dialog box.
  3. Save and name the scene “WALL-WINDOW-FURNITURE”.

(See the Wall-Window-Furniture Scene below)”.

Notice all groups ie WALL, WINDOW, and FURNITURE are visible in Outliner)

Step 2:
4. Use the Hide command to hide the FURNITURE group. Outliner now shows the FURNITURE group greyed out.
5. Check ON all the “Properties to save:” in the Scenes Dialog box EXCEPT Hidden Geometry.
6. Save and name the scene “WALL-WINDOW-NO-FURNITURE”.

(See Wall-Window-NO Furniture Scene below)

Notice the FURNITURE group in Outliner is greyed out)
STEP 3:
7. Double click the WALL-WINDOW-FURNITURE scene to activate that scene.

(See Wall-Window-Furniture Scene below)

Notice that the FURNITURE group is hidden!

ChrisDizon wrote: “Here is what is now in the users help center …
“The Properties to Save options are used to control the different properties that can be
stored with each scene.” … “Hidden Geometry: Use the Hidden Geometry checkbox to store the hidden geometry visibility with the scene.”

If I understand this correctly, checking the Hidden Geometry property to save ON and saving or updating a scene, that hidden geometry visibility should be maintained when one opens that scene.
This is NOT what is happening!

Jim wrote:
“All of the Scene options are consistent and logical. If an option is checked, the Scene uses the settings to update the view. If an option is not checked, the Scene does not use the settings to update the view.”

I don’t see how the scene options are either consistent or logical. By the above experiment the Hidden geometry for the FURNITURE was checked ON. According to Jim, the Scene should use the settings to update the view. After creating a second view where the FURNITURE was HIDDEN … the Hidden greometry property was NOT SAVED… the first Scene “Scene No1-No-Hidden-Geometry.jpg” did not save the unhidden state!

It is my request that this be corrected. The corrected “Property to save: should be renamed to “Hide-Unhide Settings” and by checking checkbox ON it should hold the saved scene’s hide or unhide properties.

All other “Properties to save:” result in What-you-see-is-what-you-get (WYSIWYG) view of the model.

All other “Properties to save:” act like a snapshot of all the view settings in the model EXCEPT “Hidden Geometry”.

Hidden Geometry should be corrected to be WYSIWYG the same as the other categories.

Camera location is WYSIWYG.
Visible Layers is WYSIWYG.
Active Section Planes is WYSIWYG.
Style and Fog is WYSIWYG
Shadow Settings is WYSIWYG

“Hidden Geometry” is the only property that is NOT WYSIWYG !!


#6

There is another broken feature in SU. This is something I’ve noticed while using the Hide and Unhide commands.

After hiding a nested group … the Edit/Unhide All command DOESN’T WORK !!

Step 4:
8. Select the Edit menu > Unhide > All command. The hidden nested group named FURNITURE does not unhide. I would like to see UNHIDE ALL do just that … unhide ALL geometry including nested groups. After all, in my opinion groups (particularly nested groups) are extremely important to efficiently working in SU.


#7

Hi Paul,

Yep, that’s the way it works.
You’re simply using the wrong tool to control visibility.

Ranting up the wrong tree won’t resolve the issue.
Learning to employ the tool designed specifically for the task will get you out of the woods.

SketchUp’s Layer System was deliberately designed for just one task; Visibility Control

Use of the Hide command to control visibility often leads to confusion.
Best to use it sparingly, if at all, and then only in the topmost modeling context. Here’s why…

Edit > Unhide > All … is always context sensitive.
Edit > Unhide > Last … Works globally only once, after that, the Unhide command is context sensitive.
Globally means the context of the entire model space and the modeling context within all groups.
Context Sensitive means an operation affects only the active modeling context.

So if you hide an entity while editing a group…
Then you must re-enter the editing context of that group to unhide the entity.
Obviously, use of the Hide command to control visibility of nested groups becomes a cumbersome affair.

If you insist upon using Hide to control visibility then this little plugin will probably come in handy.
You might also find it useful to insure nothing remains hidden should you decide to adopt Layers.

Unhide All by R. Wilson


#8

The Scene Properties can be quite a brain twist especially since there are so many variables to know about. Dont let this dishearten you because what you are trying to achieve can be done while leaving all the settings CHECKED. :smile: In fact most users dont mess with these properties that often. I, myself, tend to only turn off Camera Location when I dont want to set camera views from scene to scene.

Turning elements visually ON and OFF can be done different ways depending on how you chose to organize your model elements. Using the HIDE/UNHIDE feature with scenes is one way. As Geo mentioned, placing grouped elements onto Layers with scenes is another way. Either way, leaving the Scene Properties all checked will capture the elements’ state as you create your scenes.

TIP: Be sure to get the model elements in the state you need BEFORE you create the scene.

Here is example showing the use of nested groups, layers, scenes and the hide feature.

I hope this helps

Cheers
CD


#9

Hi Paul,
Do all your scenes with the use of saving per scene the layerset(s) that are on or off, depending on what you wish to see in these particular scenes. Forget about the use of hidden geometry with the ‘Hide’ command. This can be very frustrating and confusing, for scenes do NOT keep in memory what is hidden as nested geometry. Only the topmost level is consistantly saved per scene. You already experienced something similar.

So in other words: a scene shows what is visible by layers that are on.
If you select another scene that didn’t have ‘Layers’ checked when saved, then the previous layerset (of the previous scene) will be used again. Very consistant, more or less as in other programs.
Visibility in a scene is obtained working its way down to where a (nested) entitie’s layer may be off. That entity and all that it contains (nested downwards) will be invisible. This is (will be if cheked) stored in the saved or updated scene.
Only top level geometry’s visibility can be controled by the use of ‘Hide’ and saving that in scenes. Hence not that useful for scenes. Itś more for modeling/editng purposes.


#10

Thank you all for your explanations.
They are very helpful.

CD, Would you allow me to download your SU example? The GIF file is like watching a magician do his tricks. Thanks.


#11

Hi CD,
No need for me to download your SU. I guess I was just hypnotized by the gif. Thanks.


#12

The other complication in all this is that STYLES will also interact with scenes - so merely toggling face style or hidden geometry off the main pull down menus and saving the scene will still be overridden by whatever your style settings are and if their settings are being applied in the scenes… been driving me crazy over the last few weeks…