Scaling along axis

I seem to be missing something when it comes to scaling. I have used ctrl, shift, and at different points but it keeps taking the component off of the blue axis. I try the handels on the end but even with shift or ctrl, it will not constrain. Do i need some other button combination? I need the spring to stay attached to the blue axis its constrained to. but it keeps moving away. If an object is floating out in space, i know there is a way to “home” it but i forget how. Just having some slight troubles with these two items today haha


What are you trying to do? Pulling straight out on the center/end point should work to stretch the coil straight , if your helix inside the component and the component are vertical. But pressing Shift is going to give you a proportional scale so the object will move in x and y as well.

If you are lost in space try Zoom Extents in the Camera menu so you see all of the model, then you can grab an object and put it back where you want it.

Im trying to get it to scale down by 0.001 but it doesnt keep it attached to the orgin, it throws it way out there, then i jave to hit ctrl+shift+e to find it and drag it 20 miles. I do know there is a way to send it “home” and type 0,0,0 somwheres. Anyway, i just can not get it to locked/attached when i scale it. I need it to stay attached to orgin or at least on the blue axis line:) thanks

Then I can’t think what is happening. Maybe if you post the file, someone will figure it out. If you have an object you want to send to the origin, select it and move it a little distance then type in [0,0,0] with brackets.

Use the handle diagonally opposite from the origin.

1 Like

Oh you want it scaled proportionally not just on the blue axis? Does it matter that there’s a tag piece sticking out the side at the bottom? The coil itself is not going to stay in any particular location when the object is asymmetrical like that.

Ok, i will use the bracket option to move it. I actually deleted the part. I will post file later today when home, if i remember:)

Did that, and no go. It scales it proportionally like i want, but throws it out into space. I tried every single handle with ctrl, shift and still throw it out into space. I finally just moved it with [0,0,0]. Not sure if its an issue with the shapes extension or how the helix is placed on the blue line. I spent about 35 minutes messing around with it and finally gave up. I deleted the file. I will try again tonight and report back…

Thanks for all the tips though

I don’t know what it is you are trying to do. The scale tool works from handle to handle and will either scale from one handle to the other or about the center.
So an object positioned at the origin will scale down to the origin, keeping the relationship of corresponding point to the origin, or it will scale about it’s center keeping the center related to the origin.
If you want the center of your object to remain on the blue axis line then you need it to be centered on the axis to begin with. If the object isn’t symmetrical then the center won’t be the center.


If you mean something else then we need a clearer explanation and a model.

what i said in the post above is what iam trying to do. I just want to scale it down proportionally by 0.001, and have it stay put at the origin, but it was throwing my part out in space somewhere. It was not keep it attached to the origin at all. So i would have to zoom extents, then move to [0,0,0]. I know the part was centered at the origin because when the shapes extension draws the helix, it places it on the origin:)

And i do not have that centering move to origin option. Is that an extension as well?


Then you need to attach a model that shows this behavior for us to be able to find the issue.

i will, but i know it will work for you guys haha. Thats what always happens. I deleted the file yesterday but i will create a new one. With the current file, I purposefully moved the part 1.25 meters off of the center.

threads not scaling.skp (153.7 KB)


It’s doing exactly as I said above, if you are scaling about the center to .001 then it will be very small in relation to your screen and quite a long way from the origin. But that is the centerpoint of the original unscaled component.
If you are scaling from one diagonal handle without using ctrl or shift it will scale down to a very small object at the opposite corner of the original bounding box.
If you want it to stay at the origin, then you need to center it on the origin or have the bounding box corner at the origin.

1 Like

Shouldn’t your helix be centered on the blue axis? I’d start there…

1 Like

Exactly, it should work at the center. It was not working for me at the center yesterday, that was what was making me frustrated and why i started the thread, then deleted the file. It was attached to the origin, and each time i scaled, it flew into space. My version of SU has had some odd things happen. I have sent many a messages to another user trying to figure out something. We came to the conclusion either corrupt file or re-install, which i have done twice haha.

Well, since you got it to work, i will try it again with a all new file and on my BIG pc and not the lap top.

Last question before we can close this thread. Is taht an extension you are using to right click and center? or is that a feature of 2019?


It’s an extension called centering.

1 Like

thanks, i will look for it. Sorry for this thread and inconvenience but im thinking of dumping SU on my laptop and sticking with SU on my big pc. I have so many issues on my laptop…

Are you sure you aren’t just misunderstanding what is happening when you scale so small.
Here it is scaled correctly to .001. It becomes tiny and is not near the origin because it has scaled to the center of the original.

1 Like

Well, i dont know. Because when i ever i create a helix with “shapes” it puts it right at the center of the first helix, as if it was a circle.

Here is what i WANTED it to do last night on my laptop. I just jumped onto the big PC and it worked. But i know for 35 minutes last night it did not do this for me at all on my laptop…