Scale handles hard to handle

Sometimes they are big, so I cannot tell them apart when I scale a small object, and sometimes they are small, so I cannot really see them.

I would rather they be sized as a ratio of the screen size, just like the snap handles. They’re always the same size regardless of zooming and screen resolution, and that is what makes them work well.

Nornaly they stay the same size like inference points. (I guess thats what you mean by snap handles…)
Maybe something to do with your video drivers, i’m not shure…

Possibly, but they’re not the same distance apart when you zoom in or out. You would normally zoom in if they are too close together.

its mostly a problem (on the Mac at least) for small and long objects, as seem here:

and if I zoom further in on the object shown in the last post, I get these large and overlapping handles. :

I have seen this too (on PC), but not too sure about how to reproduce it. Distance to origin and overall model extents might also have a hand in this.

image
image

A… cool. Thanks. Turning off perspective while scaling long things will work. :slight_smile:

There is always at least a workaround… :slight_smile:

1 Like

The scale handles are drawn as 3D objects, sized to match a certain pixel size at the centroid of the selection. In most cases this works just fine, and gives the benefit that the depth of the handle is clearly conveyed, and you can intuitively interpret their position in 3D space on a 2D screen.

However, it doesn’t work ideally when the centroid is either outside the view, or the selection is viewed along its axis. I don’t know if the logic could be tweaked to work better in these edge cases.

I agree its hard to pinpoint exactly how it could be controlled on really long and thin objects, without making the programming logic too convoluted, except maybe with a max display size per handle relative to the screen size. That way one can mostly zoom in to a place where the handles are not overlapping, if one is not making objects that are so small that clipping will occur when zooming in.

I have a lot of standard sized thin and long parts in my modeling, and I’m mostly making those ready made components with just one scale handle, for the length. That solves it for me . :slight_smile:

If you want to disable scaling in other directions than the length, there is an extension for that. I’ve set up Ctrl+Up Arrow for toggling blue axis handles, Ctrl+Left Arrow for green axis handles and Ctrl+Right Arrow for red axis handles.

It would be nice though if SketchUp automatically could hide the diagonal handles for items with a certain length to width ratio.

1 Like

Yes, DC’s are still handy for that!