Green grips of Scale command are too large

I am new here so please be kind.

I am having an issue with the scale command. The green grips on the yellow line that help scale groups and components are too large and I can’t scale as I want. It is becoming too irritating.
Any help and advice would be appreciated. I am attaching a screen shot

Note: For larger groups and components, it works fine. Seems that my component’s face (which I want to scale) is a little small for the scale tool. But I need to the scale too now and then so I’d appreciate any help. Thanks.

I got it now.

The solution is to get inside the group/component, select what ever you want to scale (The face, in my case) and then scale it. Did just that and worked now. Thank you. Just in case anyone has the same trouble as I did.

The handles are shown at whatever size would make a handle in the very center of the bounding box have a defined pixel size. If you position the camera with some scale handles very close to it and some very far away (relatively) those close to the camera will look very big and the other ones equally small. This has nothing to do with opening and closing components, just the position of the camera. Just try moving the camera a bit and the problem usually goes away.

2 Likes

Thank you very much for leaving a reply. I tried moving the camera and it does make the grips appear a little smaller but the issue with handling the scale grips remain (I suppose it’s because the face of my component was really small compared to the entire model).

The size of the component relative the rest of the model doesn’t affect this. It is all about how close to the camera the closest handles are relative to how far away those furthest away from the camera are.

The grips are shown in the perspective view of the model to give a sense of depth. Often the handles are on about the same distance from the camera but if you view a very long component, e.g. a beam or pipe, from its short side the furthest away handles can be a hundred times further away than the closest ones. Due to perspective foreshortening this makes the closest grips a hundreds times bigger than the ones furthest away. If you move the camera to look at the beam from the side instead of its end you’ll see a more even size of the handles.

Somewhat related: If you struggle to a center grip (axial scaling grip) this plugin lets you disable the diagonal grips for a certain group or component: http://extensions.sketchup.com/en/content/eneroth-scale-tool-handles

2 Likes

Not compared to the entire model, but compared to the components other two dimensions.
Temporarily draw two edges perpendicular to eachother and parallel to the small end face and group them together with the component. Now the grips should be more separated.

1 Like

This seems like a good idea, i don’t know why I didn’t think about that. Thanks.

With Pro, you can select which scale handles should be used for components Dynamic Attributes

1 Like

Thanks Mike, will check that one out.

This plugin has some benefits though over the DC plugin though

  • Easier to access - you don’t need to dig the into the component attributes dialog and add a specific attribute.
  • Diagonals are automatically handled - disabling Red scaling also disables Red-Green, Red-Blue and Red-Green-Blue scaling.
  • Can be accessed using shortcuts.

2017-12-14_10h33_50
(Note that there’s currently a small bug in the plugin preventing immediate updates to the scale handles. A bugfix has already been submitted to the extension Warehouse and is probably live within a day or two but until then you need to manually re.select the select tool for the axes to update)

1 Like

Thank you for the info :slight_smile:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.