Scale grip handles disappear once objects are grouped

Hi everyone! Need your help. If I group objects and try to use scale tool only Z handles are there for 3D object and no handles are visible once grouped plane is selected. Once I double click to edit group and use Scale tool all handles are there. Please help fix this.

here is a video:

and some screenshots
grouped plane:

grouped solid:

inside groups:


here is a file just in case:
Untitled.skp (106.4 KB)

I don’t know how you got them that way, but both of those groups have behavior set to allow scaling only in the z direction. The simplest way to reset this is to explode and the recreate the groups, as this is not something that is accessible otherwise via the GUI (so far as I know).

I see the problem in your file, but if I explode and Group your cube, it then behaves itself. Not sure yet what is different about your group.

Exploding and grouping again does not fix it.

It did for me. Do you have some extension that could be causing this?

Really? It worked for me.

scale

Forgot to mention it’s Sketchup windows and I’ve set a shortcut for Make Group and maybe that’s what causing this problem.

Dave has a point, as this setting is accessible via the Ruby API though not via the GUI. Typing some Ruby is how I found that behavior setting is the source of the issue.

I show it on Windows and Steve on Mac. Same result. I don’t think a keyboard shortcut would do it but what happens if you use the Context menu?

I used the built-in shortcut to remake the group, and that also worked. What have you got the shortcut set to?

I’ll check context menu a bit later when have access to my computer. It actually worked as it supposed to work before I’ve set a custom shortcut to Ctrl+G. It behaves actually like Profile Builder groups, and I have Profile Builder 3 installed. Maybe that’s causing the problem? I’ll check it

If you can take a screenshot of your Preferences->Shortcuts scrolled to show the relevant shortcut, that will help clarify the situation.

I’ve tried exploding and grouping again - didn’t work. I’ve reset all hotkeys - didn’t help. Uninstalled extensions - didn’t help.

I’ve tried assigning shortcuts both to Edit/Item/Make Group and Edit/Make Group and got the same result and Scale tool behaviour. These are screenshots of hotkeys.

Screenshot_4

Try disabling the jbb extensions in the extension manager

1 Like

Those are the same hotkeys I have set, but I don’t get the same results as you.

That leaves a possibility that an extension is using observers to monitor the creation of groups and intervenes to change this behavior. Are you absolutely sure you don’t still have any extensions active?

1 Like

You guys are right - I’ve disabled all extensions and it start working properly this time. I’ll start switching them back and see which is causing the problem.

UPD: I’ve disabled all extensions, restarted SketchUp and everything started to work properly. I’ve enabled all extensions one by one and everything is still working. So probably disabling / enabling extensions is a solution.

Thanks everyone, you are the best!