Saving Components for Future Use


#1

I recently migrated from SU8 to SU2015. What’s up with migrating components from SU8 to SU2015? I don’t see anything in the components folder from SU8 and when I try to save a component that I create in SU2015 (by left clicking >save as) I am not able to save it for future use. Can someone enlighten me by sharing what I am doing wrong?

Thanks


#2

probably meant right click, however you are then taken to the windows explorer, then you save to the chosen folder…then what happens?


#3

In your new install of SU 2015, click … Window > Preferences > Files
The Preferences - Files panel is where you assign the default location of each file type used by SketchUp.
Click each file folder icon in turn and point to the appropriate folder.



#4

Geo,
Thanks for replying. I did change the default location and but that did not give me the result I’m looking for. What I want to do is be able to access (mostly) 2D components I create from the components browser. In SU8 I was able to create folders in the components browser and save (right-click on the image>save as) my components there for quick access to the components. I realize the folders in SU2015 are located in different places than before, however when I try to take similar steps to save my components I end up with the following:

Thanks in advance for reply
DesigningWoman


#5

By default Windows limits permissions to folders within the Program Files folder.
Even if you are an admin.
This caused issues with Plugin installation etc, so more recent SketchUp versions give you your own User Plugins folder.
You can path to any location for your Components [or Materials] collections locations.
So you could choose somewhere in your own Documents path where you have appropriate permissions…
But if you want to keep your Components inside the main SketchUp folder path then you’ll need to reset the folder’s permissions…
Navigate to the SketchUp folder.
Select the Components subfolder.
As an Admin…
Right-click > Context-menu > Properties > Security
Edit and give yourself and anyone else listed FULL read/write permissions to that folder.
Apply/OK
The new permissions should trickle down to subfolders and files within the modified folder…
Now you should be able to add subfolders and files into those…

I also suggest that you find the SketchUp.exe file in the main folder.
Select it and use the Context-menu > Properties > Compatibility…
Make sure that the option near the bottom to ‘always run this program as an administrator’ is ticked.
Apply/OK


#6

TIG,
Thank you so much. I was not thinking clearly about what the message is stating. Changing the permissions totally worked. And Thanks for the tip about changing the permissions/compatibility for SU. This helped me a great deal.

DesigningWoman