Sandbox Stamp odd behavior


#1

I created a terrain, following the steps I learned from YouTube tutorials. I then created a very simple house to put on the terrain (a hill). I moved the house to hover above the hill, then I used the Stamp tool to make a place for the house on the terrain. After that, I moved the house to sit on top of the stamp in the terrain.

The problem is that when I used the Orbit tool to change the angle of view, the stamped portion of the terrain moved out of its location on the terrain! When I Orbited to the right, the stamped terrain moved off the rest of the terrain to the left. When I Orbited to the left, the stamped terrain moved off the rest of the terrain to the right! So it was not in a single location in the model, but Orbit was actually moving it around! (I wish I had saved some screen captures of this…)

To get around this, I copied the stamped terrain to the clipboard as a group, then deleted the original. After that, I pasted the stamped terrain and moved it to where it belonged. After that Orbit worked as expected and I could view the house on the hill from any perspective and see what I expected.

Can anyone explain this behavior? Or is it the bug that it seems to be?

thanks!


#2

Have you reset the axes ?
Is the Blue [Z] axis ‘up’ ?
I’m wondering if you haven’t oriented the ground/house suitably…


#3

Sorry, “reset the axes” of what? The house? The ground? I can’t imagine how anything in my model would have an axis different from the overall axis of the whole model. I don’t recall ever rotating anything in this model…

What would be a “suitable” orientation?

Thanks.


#4

The behavior you describe is akin to a Component with Always Face Camera attributes.
As one orbits camera position, such components rotate about their Z Axis to always face the camera.

Should the Z Axis of such a ‘Face Me’ component be placed some distance away from the center of the geometry, the component will appear to swing in an arc rather than simply rotate in one spot.

Sharing the model would have been far more useful in diagnosing the problem.


#5

I had this exact same issue. I worked out that it was because Steve was in the middle of my stamp. And Steve is set to 'always face me’
I had forgot to delete him when I set up the topography, but once I deleted him, the stamp stayed put :slight_smile:


#6

Thought this sounded plausible, because “Susan” is indeed intersecting my stamp. But when I tried to recreate the problem just now, it did not occur. Hmmm…