Rounded edge around a curve


#1

Hello there, I am trying to create a rounded edge around a curve. Could anyone please assist?


#2

You could use Follow Me for that instead of Push/Pull.
FM


#3

Hello Dave, thank you for your reply. I am having problems using this method.

Firstly, I am not sure exactly what buttons you are pressing on your keyboard throughout and secondly you will see in my screenshot that there are vertical lines on my curves which I think are interfering with the command.

Could you please advise?


#4

I just hit the keyboard shortcut for Follow Me after selecting the edge. Then I clicked on the face on the waste side of the arc at the end. You could get Follow Me from the Large toolset or the Tools menu if you wish.

You need to soften the vertical edges around the radiused corner. You can hold Ctrl while running over those edges with the Eraser tool.


#5

Thank you again for your reply. I did soften the edges but that doesn’t seem to have made a difference to using the follow me command.

Could you please check out the file and let me know whether this is any different to your example?Bookcase.skp (71.7 KB)


#6

FM

I’m guessing you want to go all the way around the three sides of the book case top. In that case, select the top and it’s bounding edges by double clicking on the face. They hold Shift and deselect the face as well as the edges at the wall end. Then get Follow Me and click on the little face outside the arc. I didn’t look at your arcs very closely but I suspect they aren’t quite perfect because I had to erase a bit of geometry after the Follow Me operation.

One thing you can do to make the Follow Me operation go a little more easily is make the top 12mm or so over sized on the three sides. Then you can run Follow Me in one operation and round off both the top and bottom edges in one swell foop.
FM

I think it’s a good idea to get comfortable with doing this sort of thing with the native Follow Me but an alternative would be to use Fredo6’s Round Corner extension from Sketchucation. It’ll achieve the same sort of result for you.

By the way, it must be a modern bookcase for someone who keeps their books on their Kindle. No shelves. :smiley: :smiley:


#7

Hello Dave, thank you once again for your reply.

I have followed the demonstration and your steps but can’t seem to get it to work properly.

When I double click the top face and then press shift to deselect the edges as you have done so that they are not longer highlighted in blue, then choose follow me, it removes the edge from every side (including the parts that I deselected).

Why is this happening?


#9

Also, if I use the follow me tool manually, it does work, but I am left with a problem on the bottom side around the curve. This is despite me using the arc tool, clicking on the top and bottom and then the midpoint on the edge. When I created the curve, I created it on the one face and used the push/pull tool so top and bottom should be the same, yet this gap only appears on the bottom, why?


#10

You didn’t deselect the face along with the edges. Follow me will follow all edges of a selected face.


#13

Hello Box, when I said I deselected the edges as instructed, I did:

When I then click on the follow me tool, the selection disappears (which seems to happen in the demo too). However, unlike in the demo, it creates the effect the whole way around.


#14

The face is still selected!
Deselect the face and it will work.
The selection does disappear when you get the follow me tool, but it does its job.


#15

Wow, thank you… That had been beating me for hours.

Now I have it working, why do I have so many lines along the curve?


I tried using the smooth curve tool but that creates even more lines.


#16

Go to the menu View and untick hidden edges.


#17

Thank you for your reply.

I unticked ‘show hidden geometry’ which removed the lines from the straight parts. I think you were referring to the following, which was not selected anyway:

So I am not sure how to remove the lines on the curve still.


#18

While they are selected , right click and choose soften, then adjust the slider to suit.


#19

Hello Box, that is fabulous! Thank you, I didn’t see the box on the right to adjust the slider before.