Rotating a plan

I feel I should know the answer to this one.

Here is the plan of a house:

The reason it is on the skew is that it is geolocated. But in the scene, I would prefer it to appear parallel to the screen. I know I can achieve all that in Layout quite easily but is it possible in Sketchup without mucking anything else up?

See Rotating a view

There’s a plugin by TIG on the SketchUcation Plugin Store, and another on EW by Eneroth.

Thanks John. I downloaded the Eneroth one since Dave recommended that one too. Makes it dead easy. I was expecting there to be a native tools way as well. Anyway, this works a peach.

There is. Open the group or component, right click on either the red or green axis lign and choose Align View.

2 Likes

Thanks Dave. I thought I tried that but I must have been doing it wrong.

I too thought I knew this and struggled to get it to work for some reason. Looking at it now, I realize more how to use it. @Dave is using the component’s axes to orient to, but you can set the global axes for the whole model and do the same. You can save the axes with a scene just for use with that scene and not necessarily the rest of your modeling. The last time I struggled with solutions for this problem, it was a (reflected) ceiling plan. If you set the axes so that Blue is positive down, and then align view, you end up looking up at the ceiling and you can arrange the orientation.

True. Having seen plenty of models from others that have been screwed up by the user changing the global axis, I prefer to leave them in their default location most of the time.

True. I’ve had to get used to having multiple scenes with different axes locations because of Match Photo. (It works best if each photo has it’s own axis setting.) To combat the problems that causes, I’ve developed a routine of having a “home” scene or even speed modeling scene that has the axes reset if not other settings to help speed things up. I try to get in the habit of hitting that scene before going back to general modeling.