Roof trusses telegraphing through decking


#1

Link to my model: https://drive.google.com/file/d/1WWtVGdIH7t1Q6ggbW1UUHiR2sHrqm9G4/view?usp=sharing
If you select the first scene ‘everything’ and zoom in and out, when you zoom out the roof trusses read through the rood decking.
If you zoom way in, this stops happening.
How to avoid this?
I don’t want to explode the roof truss group, nor the roof truss components within that group.


#2

That’s just a limitation of OpenGL which is responsible for determining what appears in front of what. As you zoom out the proportional distance between the face of the sheathing and the truss is reduced and at some point is considered to be the same distance which makes the edges show through. The fix is to put the truses on a layer different from the sheathing or shingles and turn the truss layer off when you don’t need to see it. Exploding groups and components won’t help anyway so you don’t need to worry about doing that.


#3

Thanks DaveR.

That will work!


#4

You’re quite welcome.

You’ll probably want to reorganzie the groups,components on layers a bit so you can leave the exposed end truss visible while turning off the others.


#5

Another option is to hide the top edges of the truss component.
As you see here, two edges hidden.
Top%20edge


#6

One can simply hide the offending edges as shown near the cursor.
Viewing the model in Monochrome also reveals many reversed faces.


#7

Thanks, that might be easier than making the trusses not visible in some scenes.

The lower chords of the trusses will likely support lighting fixtures, which I’ll want visible.


#8

Thanks Geo.

What is the disadvantage of having some reversed faces in the model?

I recently noticed that under Style, Edit, Face Settings, I can select the back color to be the same as the front color, white, for example.

I often Reverse Faces when SU decides the visible face should be that default light blue.


#9

Decide how you may need to show the trusses in other scenes. You may want to show the trusses without the sheathing from above. Will you want to see the edges then? Managing hidden edges between scenes is tedious at best.

Geo has a good point about the reversed faces in your model.

There are a number of issues related to having exposed back faces related to the way certain tools such as Push/Pull work. Also, many rendering applications won’t render back faces even if they are painted with textures of materials. They end up being black as if there’s nothing there.

Yes, it’s possible to make the back face color the same as the front face but that isn’t fixing the problem. That’s just masking it. Don’t do that.

The visible front faces should be white. Back faces should be blue if you are using the default styles. I edited the back face color for my default style to be a green I’d never use in my models. That makes it easier to see them when they occur so I can fix them immediately.


#10

Back and front faces tell the software which way the ‘normals’ of the geometry are facing. This can effect plugins and vanilla tools but more importantly Renderers and 3d printing.
Many render systems ignore back faces causing all sort of black faces or artifacts, 3d printers need to see what creates a solid.
A simple example, a cube within a cube is either a solid or a void depending on face orientation.

You may say none of these are relevant to you, but clean modelling will always help in the long run.


#11

Managing hidden edges between scenes is tedious at best.

Seemed that way as I first thought about it.

But there are only two components I need to deal with.

I made two versions of the roof framing: one with visible edges, one with hidden edges.

Placed them in separate layers.

When I want to zoom in and out and orbit, I’ll do so in a scene with the hidden edge roof framing.

Thanks again.