Revit to Sketchup

revit

#1

I am currently trying to use take a model I have designed in revit into Sketchup. I have used the built in way but it doen’t do what I need to I downloaded a Revit Add-In. This add-in however turnes all my walls smooth and now I have a tone of hidden smooth lines everywhere in my model. I have tried using selection toys by Tomtom to help with the selection process so I can use the soften edges function and then delete the lines but this is causeing more problems. Any help would be usefull.

This is the Revit Add-In I am using
SimLab Sketchup Exporter for Autodesk Revit

Here is my model
https://drive.google.com/file/d/1MMMXILZeRU1RBvc2hZgAUhWqOSxMqjWm/view?usp=sharing


#2
  1. I would first get rid of all the furniture and equipment form your view. You can put them all on a layer and then hide the layer. This leaves just the building elements.

  2. I would select each structural group individually and then use ThomThom’s CleanUp extension. This will remove the triangulation from the majority of the model.

BTW… Without the interior equipment, the model is only 8.2 MB.


#3

I haven’t had the need to transfer models fro Revit to SketchUp for some time, but when I last tried, the results were quite acceptable by exporting to DWG from a 3D window in Revit.

  • I used the mesh option instead of solid geometry
  • I turned Detail level to Coarse.

The result has some quirks, like being split into innumerable unique components.

Today I would perhaps try exporting to IFC and importing that into SketchUp. As always with SketchUp, there are many ways to skin the cat.


#4

Hey there. I get revit models all the time. Revit models are hmmm. As Chris says, Cleanup is the ticket. You can just select lumps of geometry and merge faces, that’ll get rid of all the triangulation.


#5

Thanks for the respnse. Using the CleanUp extension fixed the issue I was having with all the hidden geometry. Thanks again. Now I don’t have to spend hours fixing it.