Resizing component not working


#1

Hello,
I am a novice with SketchUp. I have imported the Formufit PVC components into SketchUp Make 2017 and have tried the following 2 methods to change the length of a pipe.

A. Scaling to exact measurement:
1. Click end scaling grip and move
2. Type exact measurement e.g. 51.5mm
3. Press Enter

B. Scaling to line:
1. Draw line from opposite end of component to required length
2. Click end scaling grip and move to end of line
3. Press Enter

The first method is recommended in many online articles and the second method is recommended by Formufit. Neither of the above methods work as in both instances the pipe is scaled to a larger size when I press Enter.
I have been trying to solve this issue for the last 3 weeks and it is getting very frustrating as I would like to complete a project for my young son.
Assistance will be greatly appreciated.


#3

It seems the formufit pipes have a restriction (makes sense) to only be able to scale along the length. (DC)

In the first method, when scaling, the amount typed in is a “scale factor”, not a measurement. So if you want your pipe 50cm long and type 50 it will make it 50 x as long, not 50 cm.

The other method with the tape measure tool allows you to have an exact measurement typed and it will leave a mark at that position. Then when scaling you would inference that mark with the green scaling dot so the pipe will be scaled to that exact spot and as such its length.

So I’m not sure why the second method is not working for you?


#4


#5

Thanks for your video Steve.

I tried using the tape measure method again but when I scale and then click on the grey guide point at the end of the line, the pipe scales to a longer length. I am wondering if it is because I am trying to make the pipe shorten rather than longer.


#6

sounds like you are manually entering a scale number into the VCB? after you have your guide point or line set, drag the pipe’s scale handle to that point, you would not be entering any numbers at this stage.


#7

I am only entering a number for the length of the line I draw with the tape measure, which works correctly. I then click on the centre end scaling handle and move to the guide point at the end of the line, without entering any numbers. It is when I click on the guide point that the pipe scales to a larger size.


#8

The Scale tool accepts either scale factor numbers OR absolute measurements. Grab a handle and begin a scale in any give direction (note that one can scale in the x,y or z dimensions only or a combination of those depending on which handle you click on to begin the scale operation, the direction handles will turn red and a dotted line indicates the direction of scale). After beginning the scale operation, let go of the mouse and type a number, if you use a number only and press enter, such as 1.65 or .7 or 50 the object will be scaled by that factor. (scale to -1 makes a reverse copy) If you desire a particular measurement then type a number followed by the denomination you want, like 23’ or 18" or 65m or 200mm. The object will then be scaled directly to those dimensions in the direction you began the scale operation in. New numbers, either scale factor or direct measurement can continue to be input endlessly until you change tools, or begin a new operation.

It sounds like your Dynamic Component has some odd setup that is confusing this. You might consider just exploding the component and working with the raw geometry if the DC is not serving your needs.


#9

So you’re not crazy, I played with the dynamic component Formufit pipe a little and it behaves very oddly with the scale too. It jumped around in sizes and when rotated to a new axis it refused to scale at all, clearly there are some restrictions on the DC that interfere with this operation, it appears to be made by a third party and perhaps not very well. I found a non DC version that scales just fine that is made by Formufit here.


#10

Unfortunately by typing in the absolute dimension you are just extending the length of the pipe by that amount. The reason they suggest a line or tape, is to set the complete length. They have the dynamic component setup to only provide one handle in the center. In layer, you can reveal to shoulders of the pipe for connecting to other components.


#11

Not true. Typing in a dimension with scale tool resizes the total object to that dimension. Doing the same with the Push-pull tool adds that amount to the existing size.


#12

You’re correct, I wonder why formufit suggest doing it the way with the line?


#13

I’m not sure either, something’s off with that DC, which is a shame because direct measurements with the scale tool is the quickest way to make anything exactly as big as you want it. The extra making a line method they apparently suggest is very cumbersome.