Repeated crashing with Mac SketchUp 2021

We’ve had a few support cases, and a couple of forum posts, about Mac SketchUp 2021 crashing after a certain action, and then repeatedly crashing until you restart the Mac.

There was a suggestion about deleting the preferences PLIST file fixing things, and that may still work for some cases, but for a few other cases we have found something to blame, and an easy enough work around. If you do want to try deleting that file first, it’s here:


To know if your case is the one I mean, if you can, start a new document, open the Colors palette and click on the brick icon. If SketchUp crashes, then it’s the problem we are seeing.

It seems to happen when SketchUp is running from a location that didn’t involve giving admin permissions to SketchUp. Two example cases are:

  1. You ran SketchUp from the disk image, or a folder that is not in Applications.
  2. An admin signed in and installed SketchUp in the right location, but now you are signed in and get the crashing.

If you still have the DMG in your Downloads folder, and you are logged in as you, and not an admin, you could mount the disk image and copy the SketchUp 2021 folder to Applications, replacing the one that is there. Make sure to have closed SketchUp, LayOut, and Style Builder before doing that. You may need to enter an admin name and password for the copying to work.

If you don’t have the DMG, go into Applications, SketchUp 2021, and duplicate SketchUp. Again you may need to enter an admin name and password. Try running the Application that is currently called SketchUp copy, and if clicking the brick icon does not crash SketchUp, but instead shows the materials, close SketchUp copy, delete the original SketchUp application, and rename SketchUp copy to be SketchUp.

Either approach should fix the crashing issue.

1 Like

One thing to consider: if SketchUp splashes, you won’t get the bugsplat reporter immediately, but when you start SketchUp up again.
That might confuse some (at least, I was)

Hi Colin,

My file did crash as I use the paint bucket tool… Tried both method of remounting the DMG file to application and duplicating. Cleaned my cache, plist and ran the duplicated version, still crashed at the same spot. However when I was duplicating the file I did not have to type ad admin name or password to copy the work. Wonder if that may be the issue ?

Since I posted this topic I’ve had a couple of cases where all of the things that worked so far didn’t work. For those cases I found a different solution.

  1. In Finder, choose Go to Folder… from the Go menu.
  2. Copy and paste in this, then click Go:

/Applications/SketchUp 2021/SketchUp/Contents/MacOS/SketchUp

  1. Double-click on the SketchUp file.

That will run SketchUp as a Terminal process, and it doesn’t seem to be affected by the crashing issue.

1 Like

I found out that Sketchup crashes, and then keeps crashing at launch, when I click on the Materials button (in the Material/Color Tab).
Deleting the .plist file works, but as soon as I click on the Material button the crashing loops occurs again.

Please fill in your forum profile. This is an example of when the information in your forum profile is essential for the developers to be able to analyze the issue. What model of Mac, what graphics, what release of macOS?

Updating my profile now. Anyway I’m on Big Sur (macOS 11.1), running in a MacBook Pro AMD Vega 20 equipped.
Anyway seems much more a software bug rather than an hardware related issue.

/Applications/SketchUp\ 2021/ ; exit;

i4036on@i40-06-on ~ % /Applications/SketchUp\ 2021/ ; exit;

2021-01-03 19:38:37.003 SketchUp[5810:414371] Initializing Bugsplat

2021-01-03 19:38:37.160 SketchUp[5810:414371] <RMSplitView: 0x7f996e0846b0>: the delegate <StyleBrowserController: 0x7f993d80d000> was sent -splitView:resizeSubviewsWithOldSize: and left the arranged view frames in an inconsistent state:

2021-01-03 19:38:37.160 SketchUp[5810:414371] Split view bounds: {{0, 0}, {250, 318}}

2021-01-03 19:38:37.160 SketchUp[5810:414371] Arranged view frame: {{0, 0}, {250, 146}}

2021-01-03 19:38:37.160 SketchUp[5810:414371] Arranged view frame: {{0, 154}, {250, 165}}

2021-01-03 19:38:37.160 SketchUp[5810:414371] The outer edges of the arranged view frames are supposed to line up with the split view’s bounds’ edges. NSSplitView is working around the problem, perhaps at the cost of more redrawing. (This message is only logged once per NSSplitView.)

:23: warning: __LINE__ in eval may not return location in binding; use Binding#source_location instead

SketchUp:0: warning: in `eval’

:28: warning: __FILE__ in eval may not return location in binding; use Binding#source_location instead

SketchUp:0: warning: in `eval’

:34: warning: __FILE__ in eval may not return location in binding; use Binding#source_location instead

SketchUp:0: warning: in `eval’

:36: warning: __FILE__ in eval may not return location in binding; use Binding#source_location instead

SketchUp:0: warning: in `eval’

objc[5810]: Class SkpTimerCaller is implemented in both /Applications/SketchUp 2021/ (0x10a6696d8) and /Applications/SketchUp 2021/ (0x12392ec08). One of the two will be used. Which one is undefined.

objc[5810]: Class SKTextPath is implemented in both /Applications/SketchUp 2021/ (0x10a669750) and /Applications/SketchUp 2021/ (0x12392ec80). One of the two will be used. Which one is undefined.

objc[5810]: Class SKTextPath is implemented in both /Applications/SketchUp 2021/ (0x10a669750) and /Applications/SketchUp 2021/ (0x122c67f50). One of the two will be used. Which one is undefined.

2021-01-03 19:38:40.440 SketchUp[5810:414371] INFO: Start CrashManager processing

2021-01-03 19:38:40.446 SketchUp[5810:414371] Warning: Expected min height of view: (<NSButton: 0x7f990cdea4b0>) to be less than or equal to 30 but got a height of 32.000000. This error will be logged once per view in violation.

[0103/193842.909704:INFO:CONSOLE(7)] “Error accessing file:///Applications/SketchUp%202021/…/en.lproj//welcomescreen/en.json–[object ProgressEvent]”, source: file:///Applications/SketchUp%202021/ (7)

[0103/193842.910107:INFO:CONSOLE(7)] “Unable to find resource file for language en”, source: file:///Applications/SketchUp%202021/ (7)

[0103/193842.910234:INFO:CONSOLE(7)] “In location file:///Applications/SketchUp%202021/…/en.lproj//welcomescreen/en.json”, source: file:///Applications/SketchUp%202021/ (7)

[0103/193842.957889:INFO:CONSOLE(27)] “Uncaught (in promise) NavigationDuplicated: Navigating to current location (”/home") is not allowed", source: file:///Applications/SketchUp%202021/ (27)

unzip: cannot find or open /library/application support/sketchup 2021/sketchup/plugins/twinmotion2020.2/.zip, /library/application support/sketchup 2021/sketchup/plugins/twinmotion2020.2/ or /library/application support/sketchup 2021/sketchup/plugins/twinmotion2020.2/*.zip.ZIP.

No zipfiles found.

rm: /library/application support/sketchup 2021/sketchup/plugins/twinmotion2020.2/*.zip: No such file or directory

rm: /library/application support/sketchup 2021/sketchup/plugins/twinmotion2020.2/__MACOSX: No such file or directory

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/lbw_player.rb:90: warning: already initialized constant Lbw::Player::AUTHOR

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/lbw_player 2.rb:90: warning: previous definition of AUTHOR was here

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/lbw_player.rb:91: warning: already initialized constant Lbw::Player::CONTACT

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/lbw_player 2.rb:91: warning: previous definition of CONTACT was here

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/lbw_player.rb:92: warning: already initialized constant Lbw::Player::COPYRIGHT

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/lbw_player 2.rb:92: warning: previous definition of COPYRIGHT was here

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/lbw_player.rb:93: warning: already initialized constant Lbw::Player::DESCRIPTION

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/lbw_player 2.rb:93: warning: previous definition of DESCRIPTION was here

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/lbw_player.rb:94: warning: already initialized constant Lbw::Player::NAME

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/lbw_player 2.rb:94: warning: previous definition of NAME was here

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/lbw_player.rb:95: warning: already initialized constant Lbw::Player::VERSION

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/lbw_player 2.rb:95: warning: previous definition of VERSION was here

[V-Ray for SkecthUp LOG_INFO]:Initializing V-Ray

[V-Ray for SkecthUp LOG_INFO]:Initializing ChaosGroupCache

[V-Ray for SkecthUp LOG_INFO]:Initializing AppSDK

[V-Ray for SkecthUp LOG_INFO]:Initializing Sceneman

[V-Ray for SkecthUp LOG_INFO]:Initializing VRayCefAPI

[V-Ray for SkecthUp LOG_INFO]:Initializing NeUI

[V-Ray for SkecthUp LOG_INFO]:Initializing SceneEventPoller

[V-Ray for SkecthUp LOG_INFO]:Initialization finalized

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/vfs.rb:6: warning: already initialized constant VRay::OSX

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/vfs 2.rb:6: warning: previous definition of OSX was here

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/vfs.rb:7: warning: already initialized constant VRay::WINDOWS

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/vfs 2.rb:7: warning: previous definition of WINDOWS was here

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/vfs.rb:8: warning: already initialized constant VRay::SKETCHUP_VERSION_MAJOR

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/vfs 2.rb:8: warning: previous definition of SKETCHUP_VERSION_MAJOR was here

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/vfs.rb:8: warning: already initialized constant VRay::SKETCHUP_VERSION_MINOR

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/vfs 2.rb:8: warning: previous definition of SKETCHUP_VERSION_MINOR was here

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/vfs.rb:8: warning: already initialized constant VRay::SKETCHUP_VERSION_BUILD

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/vfs 2.rb:8: warning: previous definition of SKETCHUP_VERSION_BUILD was here

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/vfs.rb:9: warning: already initialized constant VRay::SKETCHUP_VERSION

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/vfs 2.rb:9: warning: previous definition of SKETCHUP_VERSION was here

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/vfs.rb:10: warning: already initialized constant VRay::PRODUCT_NAME

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/vfs 2.rb:10: warning: previous definition of PRODUCT_NAME was here

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/vfs.rb:12: warning: already initialized constant VRay::INSTALL_PATH

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/vfs 2.rb:12: warning: previous definition of INSTALL_PATH was here

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/vfs.rb:17: warning: already initialized constant VRay::EXTENSION_PATH

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/vfs 2.rb:17: warning: previous definition of EXTENSION_PATH was here

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/vfs.rb:18: warning: already initialized constant VRay::VFS_FOLDER

/Library/Application Support/SketchUp 2021/SketchUp/Plugins/vfs 2.rb:18: warning: previous definition of VFS_FOLDER was here


2021-01-03 19:39:28.341 SketchUp[5810:414371] Warning: Expected min height of view: (<NSButton: 0x7f983af96140>) to be less than or equal to 30 but got a height of 32.000000. This error will be logged once per view in violation.

Hi Colin, I have the same problem with the ‘brick’ . removing the .plist file helps until I use ‘the brick’ again. Your other two solutions are not clear to me.

  • I run sup from subfolder in applications (as it is installed by DMG)
    Screenshot 2021-01-04 at 14.43.40
  • I (not admin) was signed in when installing and running sup (is there a way to check this to be sure)

I have installed OpenCutList which relies on materials (the brick) for proper function and canbe part of the problem. However, after shutting down this extension the problem remained.

How to proceed ??
Since I am only a user of sup (paid subscribtion Pro) for a few days but need materials in my daily use I can only whish this is not normal procedure and will be solved quickly

Looking forward to your reply

In Finder, choose Go to Folder… from the Go menu. Copy and paste this text into the path field:

/Applications/SketchUp 2021/

That will leave you with a SketchUp application selected. Double-click on that to open it. A Terminal window will open, and run the application. Try the brick again, and see if the paint bucket is working.

If it crashes SketchUp, look in the Terminal window and copy and paste all of the text in your next reply.

This seems to work :slight_smile:
Did I run another version
How to set up for permanent solution?

(another difference is that I had uninstalled OpenCutList extension)

You may as well try OpenCutList again.

At some point we will update the installer so that the initial problem doesn’t happen. I can’t tel you when that will be. In the meantime I’m trying to find which files are affected when the problem happens, and will see if it’s possible to fix the problem after it has happened.

Thanks for the solution
So do I need to start up SUP through terminal in order to avoid the bug
or can I replace my present application with the one starting up from within terminal

You would quit SketchUp by closing that Terminal window. You could make an alias of the deeply buried SketchUp application, then double click on the alias to set Terminal going again.

One thing you may notice is that you can get multiple copies of SketchUp running. If that does happen it may be best to close one of the Terminal windows, to keep it down to one copy of SketchUp running at a time. That one copy can still work on multiple documents.

Thanks for help. This will keep me going for now. For your info;
-placed copy of alias on desktop is running oke
-(I do get bug report form which I can ignore) but application then starts fine
-original application startup folder remains corrupt after removing .plist and using brick
-when quitting terminal I can continue to work in SUP
-OpenCutList works

Just drag the SketchUp Terminal app in macOS dock. Not elegant but works as a temporary workaround while we wait for the SketchUp devs to fix the bug.

@Colin please, fix this annoying old bug that causes SketchUp to open in the second monitor instead in the first one. :slightly_smiling_face: It happens every time I open SketchUp and I have an external monitor attached in.

Checked your desktop assignment by right-clicking on Sketchup in the Dock while a second display is attached?

If you are using Mac, it could be that you have SketchUp running full screen, and the system has remembered that for each time. Try not being in full screen, make sure the window is on the first monitor, close SketchUp and reopen it to see if that has been remembered, then try full screen again.

If you’re on Windows, come out of Maximized, move the window to the first monitor, close, reopen, see if it has remembered to open on the first monitor.

Unfortunately doesn’t work.
I have a MacBook Pro and above it an external monitor (set to be the main monitor).
Even If I go on File/New (cmd+N) in monitor 1 (external monitor) the new SketchUp window opens in the second monitor (integrated MacBook monitor).
Using the fullscreen mode doesn’t work neither: a new window opens in monitor 2 instead of a fullscreen session in monitor 1.