Renewing the Discussion of the Frustrating Warning Triangle of Insanity

So–there’s already two closed threads on this–still no documentation on this topic. I’ve stopped getting red-highlights when I update my sketchup file, at least I think I’m over that learning curve.

BUT, now we’re talking warning/caution triangles after I’ve “locked” by SketchUp Model in Layout. So it’s great–I say, “haha, too bad you can’t screw with my dimensions anymore”. The way I presume this works and it’s just a guess is that the Sketchup image get’s embedded into the Layout file at this point, so nothing you do to the Sketchup file will affect an image right? Just a laymen’s guess.

AUTO-RENDER ON
Yet now I’ve got yellow warning/caution triangles on SOME of my viewports, even on ones I didn’t change. I’m going to go back and lock all my components so nothing slides around on me–but I really don’t know what I’m doing wrong now. In 2022 I think the auto-render button is now simply called “auto” if I’m correct and it’s checked all around. I even manually rendered each view-port, but that doesn’t seem to do a heck of a lot. But I haven’t yet got to photorealistic rendering–maybe that comes into play there.

Obviously I have some understanding to go–but how I can prevent this from happening in the future?

If you’re locking the viewports then you are telling LayOut that you don’t want to make any changes to them including rendering.

1 Like

Is there a way to ignore the warnings and have program refresh Layout window without them writing over your plans?

And what about generating a report about the changes made that resulted in each and every warning sign being produced? Is that possible?

No.

Not automatically. I suppose you could keep a pre-changed copy of the LayOut file and the compare it to the changed one. I’m not sure what the value would be, though.

Mitch…what’s the purpose for locking viewports in the first place?

If I read your original post, it would seem that you might have chosen to lock the viewports to eliminate the dimension unlinking issue. The natural result of this is that the viewport now sees an updated sketchup file and wants to re-render it for any possible changes. It can’t do that because you have locked it so it now delivers you a shiny new yellow triangle.

To me, it seems like unlocked viewports takes precedence over having to re-link dims. Which isn’t to say that re-linking dims isn’t a pain in the patooky. There are just better work-arounds for dim creation that can make that process easier and at the same time eliminate the yellow triable alert and keep your drawings up to date with current changes coming from Sketchup.

It can be a pain. I wonder what’s different, though. I don’t have problems with dimensions becoming unlinked in my LO files unless I edit the model in a way that removes the Persistent ID for one or more of the anchor points. When I do that I fully expect to need to re-attach or replace the dimension when I get back to LO.

So is it a difference in modeling workflow? A difference between Mac and Windows? Or something else?

1 Like

This is a great question…Don’t really know how to track it down myself.

I did this residential house remodel beginning of the year. Big steps for me. Initially when I first started getting the Layout files setup, I was having dim unlinking issues every time I updated the file. As the model got more and more dialed in and changes were becoming minor issues, not massive sections of the entire model, those unlinking’s stopped happening. The points I had them set to never changed so I couldn’t see why they would unlink.

I don’t mess around with my scenes in Sketchup so I know that the changes weren’t there. I always reset my working model scene back to it’s original saved position before I save the file after a change. So really the only thing changing is the place that was getting updated. But then back in the Layout file there were dims unlinked that were in a place where no changes had happened. Never understood this.

The problem I can see is that picking that point for the dim anchor can be tricky because there can literally be 15-20 points to select from in a 2D view of a 3D model.

Additionally, one thing I learned from @joanne during one of our Sloped sessions was that if you open a Sketchup file from a viewport in Layout, when you do updates in Sketchup and then return to Layout, the update is automatic instead of needing to use the right click menu. For whatever reason, when I started using this method, I started seeing an improvement in the dims staying linked. Weird?

My opinion is that like almost everything in SKU/LO, workflow is the issue. Mac and Windows might be another component of that, but I’m not knowledgable enough to know how to track it down if it is having an affect. But again, the biggest thing I have learned setting up Sloped and talking to so many pro level users is that 9 times out of 10 the issue is workflow and a lack of understanding about how Sketchup and Layout dance the dance together. I have certainly found out how much I don’t know in the last 9 months…and I can say with all certainty that it has changed my confidence with the platform on a whole.

Making scene-specific changes are unlikely to disconnect dimensions. It’s the geometry within the model that the dimensions are linked to.

That’s probably a good habit but as long as you aren’t using Last saved SketchUp view for the scenes, it shouldn’t make any difference in LO.

Yes but whatever works.

I tend to agree with you. I see lots of evidence of that.

:+1:

This had always been my understanding. But if I don’t change geometry and the link is busted, why is that happening?

the only thing that ever made sense to me is that I am not actually pinning the dim location to the geometry I think I am. Say in a plan view of kitchen I pick the outside corner of a tall cabinet. That corner does have a point at the top, one at the bottom, one at the countertop where it intersects with the tall cabinet, one at the crown (if it’s visible), and one at the top of the base mould and one at the bottom of the base mould.

I assume I’m picking that top corner, but what if Im actually picking the bottom corner of the base mould? If I have to change the base mould and I don’t know that’s where the dim point is connected, then every time I change the base mould the dim unlinks.

There is no way that I know of to guarantee that I’m picking the point I want to pick in a 2D view of 3D model.

Very good question. I wonder if @adam might have any insight.

The thing with picking points that are diagonally positioned in the model has been an issue for some users although I haven’t run into it myself. It might help if you are zooming in more closely to the points you are selecting. How are your viewports rendered when you are adding dimensions?

To what do you have Precision set for the Dimension tool in LO?

I have also see in some cases users have managed to only link one end of a dimension to a point in the model. The other end isn’t linked at all.

This is a big one…sometimes I can’t find a point so I just link to a line. Not best practice for sure and those definitely break a lot.

Haven’t checked on the precision level for my dims in a while…I think I have it set at 1/32" so Im not getting 1/64ths. But that’s a guess right now.

you probably are like me and can add/subtract at the 32nds level.

Indeed!

When I’m working in imperial units I always set Display Precision in SketchUp and Dimension Precision in LayOut to 64ths. I don’t intentionally model anything to 64ths so if I see a dimension such as 37/64 that raises a red flag. With precision set coarsely potential errors can be masked. If you don’t have any 64ths or even 32nds in the dimensions, you shouldn’t see the numbers in the denominators.

Since I started working with SketchUp I found my ability to do math with fractions in my head has improved.

So get this Dave, I’ve got the yellow triangles still. I’ve unlocked them and re-rendered. Locked them again. Went to print now, and I had viewports missing off the PDF.

What do you think?

Do they also show blank in LayOut? Are they victims of the “clippping bug” introduced in the latest 2022 version? For me these issues were fixed when I opened the model in SketchUp, and for each of the blank scenes, switched to Perspective and bac again to Parallel, and updated the scene.

1 Like

I’ll try that! Thanks :slight_smile: