Renaming scenes causes Sketchup to crash

In either an existing model, or a new model with no input, renaming a scene causes Sketch up to crash. In a new model, unnamed scenes can be created, but not edited. In an existing model I cannot create or edit scenes.

Hi David,

I am curious if SketchUp will crash if renaming scene with the Ruby Console.
Can you give the following a try?

STEP 1
Open the Ruby Console: Windows → Ruby Console

STEP 2
Copy & paste code snippet bellow in the SketchUp ruby console.

Sketchup.active_model.pages[0].name = "New Page Name"

STEP 3
Click enter for running code after you have created at least one SketchUp scene.

Then let me know if you can if SketchUp crashed while trying to rename current scene to “New Page Name”.

Do you have installed an extension that has anything to do with scenes?

Thanks for the response. By following the guide above, yes, I was able to change the name of the scene OK.
After doing that, I created a second scene, and tried the “normal” way (right click, change name). Froze again.

Anssi,

This is an install form only a short time ago. At this stage I have added NO extensions whatever. I intend to install a few in the future that I have used before. This is a new computer and I am just working up to these.

If you are working with it “out of the box” you should check for driver updates, especially for your graphics card (from the AMD website). Do not trust Windows for that.
You can also try repairing the SketchUp installation: Right-click on your downloaded installer file, select “Run as administrator” from the context menu, and select Repair from the installer screen.

Thanks Anssi,
I have performed both of the things you suggested. Still no joy renaming scenes. I have noticed also that I cannot rename them from the tray - no option there. I can only get the option to rename by right clicking on the scene tab. This seems slightly odd, although it is not a bother if it works. I am just wondering if the two things are related.

The Scenes tray has a popup menu that opens from the right-pointing arrow in the header. The Rename option is greyed out when you haven’t selected a scene beforehand

As anssi says…

OK. Thanks to you all. I am now OK with using the tray to change names. I wasn’t seeing it due to a bit of silliness on my part (the window was exactly sized to the scene list, by accident, and I just needed to enlarge it…)
However, I think it is still an issue with Sketchup that I can’t change the scene name directly on the tab. This adds an unwelcome delay and extra steps. However, I am not a professional user so it’s too big an issue. At least I can get the job done.
Thanks.

Did you install by choosing the .exe fil and right clicking on it and pick " Run as administrator "? If not do so and choose the repair option.