Remove Relationships between Scenes

Hi. I’m new to Sketchup, and am currently running the 30-day trial. I’ve taken on a Sketchup file that I need to amend - it has layers of the build set across different scenes, that eventually make up a complete image. I’ve started working through the Sketchup Fundamentals tutorials, so have the basic understanding of how the programme works. I’m adding new parts onto drawings on one scene and they are updating on other ‘layers’ on the other scenes, when I don’t want it to. I’ve tried Googling, but not knowing the correct terminology doesn’t help in my search! How do I amend the settings between scenes so that items added to a later scene don’t add onto the previous ones; if I duplicate the scene to build the next stage of the ‘journey’ I’d like to then add to it, but those changes not impact the previous? Any help is appreciated.

From your description it sounds like you need a little more learning about the use of Tags (they used to be called layers but aren’t anymore) to control visibility of objects (groups and components) in the scenes. It would be helpful to see your model and how it is organized to be able to give you specific advice.

https://extensions.sketchup.com/extension/960b887a-59c1-41e5-a795-24c3d0d19065/eneroth-scene-visibility Take a look at this extension. Haven’t used it myself but looks a bit faster than hiding and updating scenes manually. +1 for @DaveR’s note to make sure your geometry is grouped and tagged so you can control visibility that way.

The basic workflow is to add a new scene for each stage of construction, draw the added objects as groups or components and assign them a tag that is visible only on that scene.

The main impediment is that there is no native way to add a new tag (formerly called layer) on one scene without it also being visible on all other scenes. However, there are extensions that can make new tags visible only on the current scene, for example https://extensions.sketchup.com/extension/5fe151f4-aefe-4dcd-b37e-c0766caaa6e4/auto-invisible-layer.

1 Like

Thanks for your replies. I’ve downloaded Auto Invisible Layer (apparently not compatible with 2020?) and the two Eneroth Scene Tag Visibility and Scene Visibility extensions, but can’t seem to get any of them to work? I’ve created Tags for items on a sample from the Fundamentals workbooks (house), added windows to the “Windows” scene, grouped/components/tags, but they appear on the “House” scene. Workbook attached. Can someone please point me in the right direction in laymans terms, so I can apply the practice to the file I actually need to amend. Thanks in advance.9-Layers -House.skp (156.0 KB)

Hmm…it doesn’t work for me either. It doesn’t raise any errors, but also doesn’t do anything. Sorry for recommending one that is now broken!

Edit: It adds a menu item in Extensions to toggle its action on and off (defaults to off). Then it works fine.

Auto-Invisible Layer works for me in SU2020. I’ve been using it on several models just in the last few days.

If you don’t want the windows to be displayed in the House scene, firs turn on the Properties to save options. You have all but Camera Location disabled so changes to things like Visible Tags will never be saved with the scene.
Screenshot - 6_5_2020 , 9_45_08 AM
Once you’ve fixed that for all of the existing scenes, choose the House scene, turn off the Windows tag visibility, right click on the scene tab and choose Update.

FWIW, although this is a sample file, you are using Tags incorrectly in this sample model. Your house is ungrouped geometry and you have assigned tags to raw geometry. This will create problems for you.

Can you explain how you made it work? CAD/Sketchup is all very new. I’m quite happy building, just can’t work out this one important thing! Do I need to do anything specific to identify which parts do/do not replicate on other scenes, etc? Thanks

See the edit to my post above.

I’m still using JF_Add_Layer in SU 2019, though I realize that his plugins are no longer available for download.

This is one of those things that should be natively available in Scene options / settings — I find it way more often the case that I want a new layer to be hidden (in all but the current scene), than wanting it visible in every scene.

Does anyone know if that has been logged anywhere as a feature request?

It’s been requested a zillion times (along with things such as a hierarchical system of tags/layers), but with no result so far.

I think there have been bigger fish to fry and some other things to get lined up before that can be implemented but I know they are aware of the desire for those things.

You still need to get your head around how layers/tags and groups/components work. Your model is using them all wrong and it will make scenes impossible.

Apologies, added the wrong file, this was the pre-grouping/tags file I opened and added windows to by mistake

I uploaded the pre-exercise, file, sorry! I have opened the grouped/tagged file, ticked all the of the properties, created a new scene, built ‘windows’, updated and they have not appeared on the ‘house’ tab. Many thanks for your help9-Layers -House - KOW.skp (155.6 KB)

When I clicked on the House tab, the Windows tag was turned off in the Tags panel. I turned it on, right clicked on the House scene tab and presto! Windows visible when you click on the scene tab later.