Remove broken references from component favourites window

sketchup
advice
components

#1

Hi,

I have a number of broken references in my component window favourites list. I have attempted to remove these by the methods provided on past posts(regedit, creating blank folders to re link) but none have worked.

Has anybody successfully managed to remove broken references in SU 2018? If so, is anyone able to offer advice?

Ashley.


#2

You need to right click the SU installer file and run as administrator, select “repair” when prompted. That did the trick for me.


#3

Hi Ian, the file within program files folder?


#4

No, the SketchUp 2018 installer, that you get from the SketchUp website. You can usually find it in your “downloads” folder. If it’s not there go to the website and get it again.

You need to repair the SketchUp installation.


#5

Thanks, Ill get to it now.


#6

Hmm that hasn’t worked either. They are still showing in the component window but are missing in REGEDIT.

Did you go back to REGEDIT and locate the missing favourites that way?


#7

Repairing the SketchUp installation should have fixed registry permissions issues that likely caused the problem. But it most likely didn’t test registry entries for issues such as references to deleted files. Have you tried opening the collection in SketchUp’s components window and deleting again after the installation repair?


#8

Yes I have tried opening again in sketchup but nothing happens.

The folder within REGEDIT doesn’t seem to be present again either. See below

HKEY_CURRENT_USER\SOFTWARE\SketchUp\SketchUp 2018\UserLibrariesComponentBrowser1


#9

No I didn’t do anything there.


#10

It has been sorted - Located and fixed via the Preferences JSON File.

Thanks for input all