Any way to purge a local collection out of list?

This is so annoying, has anyone found a fix yet?
This happens every time the file path gets disconnected and I have to reconnect but it just leaves the name of the collection behind. Whenever I try and open component library and add it to favorites this happens and I just have duplicates of the same library.

You should be able to go to the “details” menu and find “Remove Collection from favorites” image
image

It will bring up this window:
image

Try copying your subfolders (inside the “Component Library”) to the User Components path.
Then they’ll automatically appear when SketchUp starts.

On Windows browse to:
"%AppData%/SketchUp/SketchUp 2019/SketchUp/Components"

Om MacOS browse to:
"Users/<username>/Library/Application Support/SketchUp 2019/SketchUp/Components"

Matt, you are looking at the style menu. What I’m Referring to is the is the component collections menu.
Big fan of your books btw.

1 Like

Lol, I realized that after I posted.

In the Components panel, if you navigate to that empty folder, then open the Details menu, you should see “remove from favorites”.

image

So the problem is that when you select the menu you want and SU can’t find the collection ( you changed the name of a file in the path) It leaves a skeleton that won’t go away even if you do this. The collection can’t be found therefore it can’t be taken of the favorites. Try it, change a name in one of the file paths of you collection. You’ll see that you SU won’t even pull up the menu. Removing from favorites only works if the collection works in the first place.

Gotcha. I thought it would at least let you select the collection, so you could remove it. Sorry.

The workaround is likely to close SketchUp and then manually edit the preferences JSON file that holds these settings.