Reduce file size by using something like outer shell


#1

Hello, my name is Kevin Wijns and i’m using Sketchup Pro with our company for several years now.
We have acces to some CAD models from a manufacturer, which we use to simulate visual setups for our costumers.
For our setups we only need an outer shell view from the CAD model, but in reality the model contains all the bits and parts that are actualy there.
In the picture you can see a control box of which we only need the outer shell, and not all the things inside as you can see on the X-ray vision. All those parts are single objects, none of them are in groups, and they make the file size extremely large.


Once i’ve tried to delete all the parts inside one by one, but it takes like hours to complete. Is there no other way, or tool, so it can only keep the outer shape, and automaticly remove everything inside?
This control box is only a single object from 10 others we have to import in our setup. After importing some extra objects our Sketchup allways stops responding and it makes working nearly impossible.

Thanks in advance,

greetings,

Kevin


#2

You can try the following

  1. Pick an outer face
  2. Right click>Select>Connected Faces
  3. Group the selection, hide the group, delete rest.

#3

Are these objects separated onto layers ?

You may be able to select by layer (in order to delete,) using ThomThom’s Selection Toys.

Or the opposite. Select by layer, and lock the things you wish to keep. Once the “keepers” are all locked. Window select everything and delete.


#4

You could [shift-click] on all the faces you see, then “Hide” them (r-click)

If you still see some bits that you think are necessary, hide them too.

Then select everything and delete it.

Go to View-hidden geometry, select everything and “Un-hide” them.

(Or you could use layers in the same way - create a layer and set it to invisible, then use the “entity info” to shove objects onto that layer - they will vanish as you move them. This has the advantage that you can swap visibility of the layers and see what it looks like before actually getting rid of the innards.)

[edit] There is also a way to select everything of a specific colour: change the materials selection drop-down to “in model”, then r-click on a colour and choose “select”. You can then group them or move them as you want.


#5

Hello, thank you for your response.
The objects are not seperated onto layers.
When we download the file from the integrator website, we get a STEP file which we import in sketchup.
The model is grouped as 1 block, which i can explode so all the components in the group are separated.
At the moment i’m working with a model that when i explode it, it contains allmost 3000 components, and in reality it’s not even that big in dimensions, but every single detail is there. For example, even a bolt has several components, so i can’t just take a bolt out, i would have to carefully select like 6 components to have the bolt removed.


#6

Well in that case, I’d use window select and layers. Make a keep layer and turn it off as gadget says.

I’d change the view to the Front ortho view. Then window select using narrow selection window, one of the sides of the enclosure.

Change the selection set’s layer to the keep layer. It should disappear.

Repeat for the other 3 sides.

Change the view to the Top ortho view.

Window select all the enclosure’s front panel and controls.

Change the selection set’s layer to the keep layer. It should disappear.

Window select the rear panel, any connectors, etc. and repeat.

Only the “guts” should remain, easily deleted by window selection.


#7

Unfortunately i’m also not an educated designer of anything like that. So i could’nt really tell how the original file is build up.
If anyone would be interested, i could share a STEP file i’m working with so you could see what i’m talking about, cause i can’t really explain what i’m experiencing … :slight_smile:


#8

Thank you,
I’ll give that a try. It would be very helpful!


#9

@vse_kevin

SketchUp Pro does not support STEP format.
What are you doing in terms of converting the STEP file to a format SU supports?

Sharing the STEP file with us won’t do much.
Share the file you’re actually importing into SketchUp.
Is it a DWG? … DXF? … Or What?


#10

I see “ifc” and “ifcZip” on the import dialog.


#11

Hi @DanRathbun

You have me confused…
What does ifc have to do with importing a STEP file?

There’s the SimLab STEP importer for SketchUp
https://extensions.sketchup.com/en/content/simlab-step-importer-sketchup


#12

from: Wikipedia: Industry Foundation Classes

File Formats

IFC defines multiple file formats that may be used, supporting various encodings of the same underlying data.

  • IFC-SPF is a text format defined by ISO 10303-21 (“STEP-File”), where
    each line typically consists of a single object record, and having
    file extension “.ifc”. This is the most widely used IFC format,
    having the advantage of compact size yet readable text.
  • IFC-XML is an XML format defined by ISO 10303-28 (“STEP-XML”), having
    file extension “.ifcXML”. This format is suitable for
    interoperability with XML tools and exchanging partial building
    models. Due to the large size of typical building models, this format
    is less common in practice.
  • IFC-ZIP is a ZIP compressed format consisting of an embedded IFC-SPF
    file and having file extension “.ifcZIP”.

And from: Wikipedia: COBie

Construction Operations Building Information Exchange (COBie) is a data format for the publication of a subset of building model information focused on delivering building information not geometric modeling.

COBie may take several approved formats include spreadsheet, STEP-Part 21 (also called IFC file format), and ifcXML.


#13

OK, @DanRathbun, now I see where what you’re saying.

Given I have a bunch of STEP files like this…
Step File.zip (75.2 KB)

How does one go about importing the model in SU?

I’m not certain whether the attached STEP file is 2D or 3D


#14

Well if you opened it in a text viewer like Notepad++, you’d see the first line reads
"ISO-10303-21;"
so it’s a Part 21 IFC file.

I renamed it to an “ifc” extension, and tried an import. It took a few seconds, then displayed “Reading ifc file”, the progress bar filled towards the right, then up popped a messagebox that simply said “import failed” with NO detailed reason why.


#15

Oh, crumbs.
Well, my folder of STEP files is still nice to look at.

That still leaves my question to @vse_kevin unanswered